Backup to 2nd Ubuntu webmin server

OS type and version Ubuntu 20.04 LTS
Webmin version 2.001
Virtualmin version 7.3-1
Related packages SUGGESTED

Hi there,

We are trying to do a virtualmin to virtualmin webserver backup.

We have created a new webserver connection to the 2nd server in the webmin servers index, which we can switch to without any problem. So we know the 2 servers can connect to each other.

Under backups, we set up the backup options to Webmin Server, enter the backup destination server details (using the same credentials we set up in the Webmin Servers index).
Note that the login is the default ubuntu user, which uses su to gain elevated root permissions.
It is not the physical root user.
Our destination is /home/backups/servers.

When we try to backup , we get the following error:

Uploading archive to Webmin server XXX …
… upload failed! Invalid RPC login to XXX
Backup failed! See the progress output above for the reason why.

On the destination webserver, we can see a new backup folder HAS been created, but with the owner being root/root and the permissions 0000. Obviously, no backup files have been transferred.

How do we resolve the RPC login issue?
We want to be able to automate the backup and transfer process.

No-one got any answers or suggestions on this issue?

I’m not sure. It sounds like Webmin RPC isn’t working with a sudo-capable user (it should, but it doesn’t sound like it is).

Test that theory by setting a password for root and using that user for your backup. If it works, we can loop Jamie in and see if there’s a bug in the way RPC authenticates or checks ACLs (which is what it sounds like).

Thanks for the update.
That was what I was thinking too.
I will do as suggested and revert back once it’s done.

Hi again,

I set the root password on the receiving server using sudo passwd root.
For good measure I also set SSH to allow login by root.
I then set the backup to webmin server and the login as root.
However, I still get the same error as before.

If I set the fast RPC to yes in the webmin servers index panel and try a backup, I get a connection timeout error on port 10001. I can connect without issues using fast RPC enabled or disabled, from the webmin server index panel.

You need to open your firewall ports 10000 through 10100 between the two Webmin devices. That’s needed for fast RPC to work.

Thank you.
It seems it was a firewall issue after all.
Our main servers are located in a DMZ and the OUTBOUND ports (10000 - 10100) on the firewall were not open.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.