Backup problem: Copying SSL Apache virtual host configuration and certificate .. .. no Apache virtual host found!

Operating system: Ubuntu
OS version: 20.04

“Copying SSL Apache virtual host configuration and certificate …
… no Apache virtual host found!”

I get this error message after running scheduled backups, where subdomains are included in the backup. The error is on one of the subdomains.

This is an oddity that I mess with. It worked fine before a recent upgrade from Ubuntu 16.04 to 20.04. It’s an oddity because it’s a subdomain specifically for handling phpMyAdmin, running through an alternative port open to only specific IP addresses managed through the Amazon firewall (port 800). It uses letsencrypt for the cert. What I have to do to make this work is this:

Normal daily operation:

  • non-ssl (port 80) points to /var/web/html because I don’t want anyone to know there’s anything useful there.
  • ssl (port 800) points to the normal document root, but of course no one can reach it unless they have the right IP address.

When it comes time to renew the letsencrypt cert:

  • point non-ssl (port 80) document root to the normal document root in the subdomain’s apache .conf file
  • change the port to 443 and restart apache in the subdomain’s apache .conf file
  • run letsencrypt
  • Change port 80 doc root back to /var/web/html
  • Change ssl port back to 800
  • restart apache.

So I am guessing that this is confusing Virtualmin backups somehow. How do I un-confuse it, or is there a better way of doing the same thing?

Question: Do you have “include subdomains” checked in the backup settings?

What I’m wondering is this: you have “include subdomains” checked, so it’s backing them up, but then you manually added the subdomain to back up and it errors out on doing that because it is already backed up.

Just a guess.

Thanks, since this subdomain only managed the phpmyadmin script installed from Virtualmin itself, I concluded it was easier to just delete the subdomain and create it again from scratch. That worked.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.