Backup failed with one alias server


I have a server alias that isn’t transfert… because the local tar.gz seems to not be created.

Here is the log :

Creating backup for virtual server ..

Copying virtual server configuration ..
.. done

Copying records in DNS domain ..
.. done

Saving mail aliases ..
.. done

Saving mail and FTP users ..
.. done

Backing up mail and FTP user Cron jobs ..
.. none to backup

Copying Apache aliases ..
Uploading archive to SSH server x.x.x.x. ..
.. upload failed! x@x.x.x.x's password: 

/tmp/.webmin/16178-incremental-2012-04-04/ No such file or directory
Killed by signal 1.

The problem is the same on my full backup…

The backup configuration use this configuration :

Virtualmin 3.90
Servers to save (all)
Include subservers
Backup all features

All other domains, subdomain and alias work perfectly… in the log they all have this line before uploading with ssh :

Creating incremental TAR file of home directory ..
.. done

afaik the alias is backed up with the main domain. Did you check if this is correct?

Here is the setup of these virtual server
|- server alias
|- server alias

The .net server alias create it’s own backup, it is successful, the domain create it’s onw backup too… but the .ca fail…

I’ve look in the tar.gz file to see in the .backup folder if there is any reference ton the .net and .ca domain and there not.

The has it’s own .backup folder with his dns files…

I have tried to delete the server alias and recreated it, the backup still fail…

I had exactly the same problem. I solved it by going to the ftp of the top server and then going to the domains folder and deleting any folders there that have the name of a server alias. After that my backups worked fine.

Tanks this was exactly that…