Autopurge of backups?


For my Virtualmin servers I have setup a backup procedure on a remote server through FTP. I have setup it also to delete automatically backups after ten days.
Unhappy it deletes nothing making backup space filling up after few weeks :frowning:

It has worked in the past but not anymore although I don’t remember having modified something. Can it be due at FTP server used ?

Side note: what is most efficient ? FTP or S3 protocol ? and is it possible to do also in S3 the automatic purge of all backups ? When I switch to S3 mode I can’t use the purge feature (it refuses !)



For me it works well on quite a few servers, though I do create a directory using the strf and not a file. In such a directory with a “date inspired” name end up the specific backup files including the archive named after the domain. So Virtualmin ends up deleting a directory not files.

Works with:

  • S3 AWS;
  • local backups;
  • SSH backups to another machine, in dirs mounted in fact via NFS, but SMB mostly.

So yes, they do get rotated in all these scenarios. Trying to drop FTP completely though. Just click the Create destination directory and drop the tar.gz extension.

Thanks but sorry confused by your answer as mine is well doing directories for each backup named based on strings I indicated !
Would you mind to share your config you use for some S3 storages ?
You do both full backup and incremental ones ? Here I have a weekly full backup and a daily incremental !

Seemed like you actually don’t (or at least shouldn’t be able to) create time and date named folders, as the option is disabled…

In AWS like in any others, the settings are the same, just enable what I wrote for a test run - that being my exact config - and report if it works or not. There isn’t much to fiddle with backups in Virtualmin, pretty straight forward as it should be.