Autodiscover works for Tbird but not Outlook

SYSTEM INFORMATION
OS type and version RHEL 9.1
Webmin version 2.001
Virtualmin version 7.3

I am trying to get Autodiscover to work with Outlook, it works fine with Thunderbird.

I have searched and read everything I could regarding Virtualmin and autodiscover and while I couldn’t understand some of it, there doesn’t appear to be anything to help me get it working.

I have it enabled, but there is no mention in the docs about autoconfigure except to the effect that it enables Tbird and Outlook to self configure.

Any help on this appreciated as I want to move people across from an old mail server, and without having a lot of service calls and frustrated clients.

Has anybody managed to get Autodiscover to work with Outlook?

Outlook has almost always been problematic it’s entire history. I’ve never gotten it to autodiscover regardless of what server / service provider I was using at the time. I’ve always had to manually configure it.

See

Thanks for responding.

Calport, I have seen that post, but I don’t see how it could help.

Autoconfigure for Outlook seems to me to be an important part of email hosting, yet it seems to be incomplete on Virtualmin. No discussion in the docs, and forum posts are often inconclusive.

Staff, anybody?

We produce both types of autoconfig file. I don’t know why it isn’t working. It’s been many years since I’ve used it, so I don’t recall the details, but I believe there is a DNS component. Are you hosting your DNS somewhere other than the Virtualmin server, and if so, have you created the necessary records? (Or, if you’re hosting your DNS on your Virtualmin server, you probably want to confirm you actually have delegation working correctly, so it really is working the way you think.)