Auto delete backup is not working

Please find the screenshot for my setting.

Why do you have 2 days(d) and 2 months(m) in the backup name.

This works fine for me