Augh! HELP please... ipv6 breaking my email, and I can't stop it :(

I enabled ipv6 on my LAN/WAN. Worked out issues elsewhere.
Now to Virtualmin and my very crucial email server.

I’m seeing some awful issues, and so far my workarounds have failed horribly:

  • Postfix DNS lookups obviously failing, yet “host xyz” works fine.

Seeking the cause:

  • /etc/resolv.conf has/had ONLY the ipv6 DNS address, and no ipv4 (I would rather use just th e ipv4 for now as ipv6 is a bit wonky anyway.)
  • I learned at boot, the above file is copied to /var/spool/postfix/etc
  • Fixing resolv.conf doesn’t fix the extra postfix copy
  • Editing the postfix copy (and doing service postfix reastart doesn’t solve it

Even worse:

  • Fixing resolv.conf, setting it to read-only (chmod 444 resolv.conf) …
  • On reboot, even though read-only, the contents are replaced by just the ipv6 DNS address!
    • The ipv4 address DOES work
    • But I find no way to get it into /etc/resolv.conf … and stay!!

I tried “disabling ipv6” in postfix. Did not help. (add this line to main.cf: inet_protocols = ipv4)

I am losing TONS of email… ideas most most welcome.

pete

SYSTEM INFORMATION
Operating system Debian Linux 10
Webmin version 1.990 Usermin version 1.834 "
Virtualmin version 6.17-3 Authentic theme version 19.85.1

For resolv.conf problem use chattr could help there!
“If you have other programs that might modify it (like a DHCP client), you’ll have to see about reconfiguring them. Or chattr +i /etc/resolv.conf after making it a static file instead of a symlink, but beware that whatever tries to write it, might not like the resulting errors.”

More info here

Take care for reversedns ptr records for ipv6 while otherwise gmail problem .

Take care you have at the virtualservers itself also the ipv6, and there for the hostname part to if using

some test sites:
https://en.internet.nl/ mail and domain
https://ip6.nl/
RIPEstat - Visibility

I don’t have any ipv6 in resolv.conf, but ipv6 working on mail and so.
But the nameserver of hoster is in resolv.conf so it could find domain/ip on the box , and because of their network settings and ip’s
But if that nameserver doesn’t do ipv6 (translations somewhere) you can use a ipv6 nameserver there to as i have on a other box
I am using external dns services!

I don’t have a etc in /var/spool/postfix/ alma8x vmin6x

Perhaps you’re running a different version. I’m on Debian 10…

Yes and no the chattr for the resolv.conf you can use however is on every OS.

Is the only part i can help , but i don’t understand your problem further.

"If you really aren’t using DHCP, my suspicion is that your provider is overwriting your resolv.conf file with a fresh one anytime you reboot. You may want to discuss that with them.

nameserver 127.0.0.1

to /etc/resolv.conf - than run this command

chattr +i /etc/resolv.conf

to make the file resolv.conf immutable (will no longer be able to be overwritten on boot)"

chattr +i /etc/resolv.conf looks like a good idea, thanks!

The rest of the stuff doesn’t matter. No symlinks. I don’t actually need ipv6 on my email server at this point.