Archiving in filemanager dosn't seem to be working

SYSTEM INFORMATION
OS type and version Rocky Linux 9.4
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0 Pro
Theme version 21.10
Package updates All installed packages are up to date
Can anyone else confirm this as a bug, I’m trying to archive a mail directory and I select all files and archive with whatever method (I’ve tryed tar.gz tar and zip) and says its archiving in background and nothing happens after that.

SYSTEM INFORMATION
OS type and version Ubuntu Linux 22.04.4
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10:43
Package updates All installed packages are up to date

I did a small file and it worked fine. I did a large mailbox and it is still compressing in the background - maybe 10min - finally made a file.

this is strange.
In the name box auto fill kept trying to use a virtualmin login. then this box. mouse off the box and it goes away and works.

Thanks, maybe it doing it slower method. Ended up using webmin backup, alot quicker.

You could try creating a plain .tar file without using compression. This should be much faster, but it will result in a larger file size.

I tried that nothing happens, just message saying its working in the background like in the screenshot.

Can you see it working in the background? Try using htop to see if the task is running, if it is, it is a case of waiting for completion. If not there maybe a bug somewhere maybe file manager or your distro

No need for htop, as it can be checked using systemctl status webmin command. It will be displayed in CGroup section.

Thats more difficult than htop but if that’s the suggested method use it

I tried just one small file using tar and no creation of archive and message just stays there.

Nothing in group section.

I used htop and got


and the same from systemctl status webmin

Yeah I tried a larger folder and same it doesn’t show compress.cgi running.
I used inspect and network tab and see its getting called with no errors.

found a error, in the log
/bin/rm: cannot remove ‘/tmp/.webmin-0-root’: Operation not permitted
/extensions/file-manager/compress.cgi?module=filemin&username=domain.com&overwrite_efiles=false&follow_symlinks=false : Failed to setup temp directory /tmp/.webmin-0-root : Operation not permitted

There seems to be an issue with permissions. I’m not sure what the problem is in your case. Could you provide a clearer screenshot that includes the File Manager table header? Additionally, could you provide a screenshot of the File Manager ⇾ Preferences: Advanced options page?

ok.

These look like defaults. Did you try rebooting your server?

I’m just testing outside the home directory and it seem to work ok.
Look like once I try to archive in a /home/domain the error happens.
I just archive /home itself and its still running.
Ok, finished and created a achive.

I then went to home/domain and tried to archive home directory and it errors.

This is not common. What is the output of the following commands:

ls -ld /tmp

and

ls -ld /tmp/.webmin

Also, do you have a custom Temporary files directory set in the Webmin ⇾ Webmin Configuration: Advanced Options page?

image

What are the File Manager ACLs set to for the user you’re logged in with in /etc/webmin/filemin?

Well I’m logged in as root and I see no root user there.

I logged into a administrator user and I can archive.

Check this code in Webmin:

In that context, what is the output of:

ls -lsa /tmp/.webmin-0-root

Also, if you manually delete it as root using rm -rf /tmp/.webmin-0-root and try again, does it work then?