Apachei erroe

Every time I try to start apache a get defrent error messages

Failed to start apache :
Starting httpd: /bin/bash: line 1: 4459 Segmentation fault /usr/sbin/httpd

Starting httpd: /bin/bash: line 1: 4576 Segmentation fault /usr/sbin/httpd

Starting httpd: /bin/bash: line 1: 4599 Segmentation fault /usr/sbin/httpd

Starting httpd: /bin/bash: line 1: 4624 Segmentation fault /usr/sbin/httpd

Starting httpd: /bin/bash: line 1: 4663 Segmentation fault /usr/sbin/httpd

I tryed to start 30 times, and everytime it does’t start and I get error, I am new to this , and if anyone knows how to fix this, everything else works fine execpt the web server, I don’t want to go thru setting up a clean server 3 linux and 5 windows remotly…

Please help anyone that knows better because I am just learning

I only know of only one segfault causing configuration problem, and that is trying to load mod_php versions 4 and 5 in the same Apache process. If this description fits, you need to disable one of those mod_php versions (comment everything out in /etc/httpd/conf.d/php.conf or /etc/httpd/conf.d/php4.conf or /etc/httpd/conf.d/php5.conf ).

If this doesn’t fit your situation, then you probably have more serious problems.

THat for the reply

  1. Is there any way for both to reside in system

  2. If not how do i remove php4 and can you site an example how to comment out php4, I intalled it because horde needed 4, when i tryed to install it.

3 How do you update script to use php5

Thank you for the reply, and by the way you have a very good software thats easy for new commers.

As soon, that i am I little more confterble I am going to bump up me license. I have the basic license right now


Yes, both can exist. You just can’t load both mod_php version 4 and mod_php version 5 in the same Apache. There is a FAQ about this here:


If you’re using Virtualmin Professional, just run everything under mod_fcgid, and don’t use mod_php at all.

What OS/version are you on? If you’re using our packages, this shouldn’t have happened by default. Our php packages should disable mod_php by default.

I am using centos 5

Hmm…Then that shouldn’t have happened. The current version of our PHP4 package definitely does not enable mod_php4, by default. Not sure what to make of that. Are you sure you’re using our php4 packages?

I got the php 4 from the php site where can i get your php4 package I can’t sem to intall it from within virtualmin., My only rason to want this is i like horde. if you have some other webmail it’s ok too, squirel to simple, for users to my country of Brasil.Value is key.

Thank you Thank you, I got it. The php 4 and php 5 are working great…The scripts I wanted to install are working. Rhe web options do there thing.[color=#008000][/color]

if you have some other webmail it's ok too, squirel to simple, for users to my country of Brasil.Value is key.

What’s wrong with Usermin for webmail? That’s what we recommend, and it’s installed by default.

Nothing wrong with every thing in lfe is prefrence. Just like i could have used other software but I choose virtualmin, I have the basic license now but you bet as soon as I can i will up my license and as soon as i get another server that wiil go in as well.