Apache2 won't start after upgrading


I have the following setup which i run Virtualmin on:

System hostname XXXXX
Operating system
Debian Linux 5.0
Webmin version: 1.517
Virtualmin version: 3.79.gpl GPL
Theme version 7.6
Linux 2.6.18-128.2.1.el5.028stab064.8 on i686
CPU load averages: 0.07 (1 min) 0.14 (5 mins) 0.15 (15 mins)
Running processes: 49
Real memory: 512 MB total, 328.61 MB used
Local disk space: 10 GB total, 1.21 GB used
Package updates: All Virtualmin packages are up to date.

I used the automatic installation when I installed Virtualmin (/bin/sh install.sh). I have set a correct FQDN.

My problem is - after I updated Virtualmin (and all that comes with that) - my Apache2 server won’t start. I press the green button for start, nothing happens. I have also tryed to done it manually thru console, same result nothing happens.

I have checked the settings under Server > Apache Webserver > Config and all the paths are correct what I can see (apache2 not apache)

What can be the problem and how do I solve it?


You’ll want to take a peek in the Apache error log to see why it’s not starting. You can do that by looking in /var/log/httpd/error_log. That should give some clues as to what the problem is.


Thansk for fast reply!

I tryed to open /var/log/httpd/error_log but got following message: /var/log/httpd/error_log: No such file or directory.

So I Googled and found another command that worked, which was the following: cat /var/log/apache2/error.log

And from that log I found the following errors that occures:

[Wed Jun 30 22:04:54 2010] [alert] (12)Cannot allocate memory: apr_thread_create: unable to create worker thread
[Wed Jun 30 22:04:54 2010] [alert] (12)Cannot allocate memory: apr_thread_create: unable to create worker thread
[Wed Jun 30 22:04:56 2010] [alert] No active workers found… Apache is exiting!
[Wed Jun 30 22:05:14 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Wed Jun 30 22:05:14 2010] [notice] Digest: generating secret for digest authentication …
[Wed Jun 30 22:05:14 2010] [notice] Digest: done
[Wed Jun 30 22:05:14 2010] [warn] pid file /var/run/apache2.pid overwritten – Unclean shutdown of previous Apache run?
[Wed Jun 30 22:05:14 2010] [notice] Apache/2.2.9 (Debian) DAV/2 SVN/1.5.1 mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured – resuming normal operations

I upgraded my RAM memory at my VPS from 512MB to 768MB but still got the same messages as above. What can be wrong and how do I fix it?

My bad regarding the path to your error_log… for some reason I thought you said you were using CentOS, when clearly your post says Debian :slight_smile:

As far as RAM goes – what do you see when you run “free -m”?

Also, I’m curious if freeing up some RAM helps… for example, what if you stop Spamassassin? You can do that by running “/etc/init.d/spamassassin stop”.

Same with ClamAV, it might free up a lot of RAM to run this: “/etc/init.d/clamav-daemon stop”

After doing that, see if you’re then able to fire up Apache.


For some reason it works now. But it was the RAM that was to little. This is the usage now with Apache2 running:

total used free shared buffers cached
Mem: 768 616 151 0 0 0
-/+ buffers/cache: 616 151

Thanks for the help!

How come Apache2 takes so much more RAM than Apache?

Yeah, it doesn’t look like you have a lot of free RAM there… I’d suggest reviewing what processes you have running, and disabling any you don’t need.

For example, many folks don’t require mailman or postgres.

As far as Apache is concerned – I’d suggest going through it, and removing any Apache modules and PHP modules that you don’t require. Loading modules you don’t need can take up a lot of RAM.