Apache2 reach the MaxRequestWorkers Limit

Hello,

Apache2 has Problems with the MaxRequestWorkers Limit. i changed it in /etc/apache2/mods-available/mpm_prefork.conf to 5000 andn make an Restart of Apache2 nothing changed

When the Limit (2003 Workers) is reached nothing is available.

How can i check which Website or anything else need so many workers?

That’s too many, and probably will just make the problem much worse.

Your app is performing badly. Has nothing to do with Apache.

You can look at top or htop or ps aux to see who owns lots of processes and what they’re doing. In most configurations, the web app processes will be owned by the domain.

the /usr/sbin/apache2 -k start owned by www-data is th reason i think many entrys in htop

www-data only owns apache2 nothing more. i dont understand this

Unless you’re using mod_php (which you should not be), the processes running your applications will not be owned by www-data. Keep looking (or fix the fact that you’re running mod_php).

I don´t know what can i do. my knowledge is at the end.

So many Start Processes from Apache2 with user www-data. I have nothing changed.

[Thu Oct 07 00:04:08.257494 2021] [mpm_prefork:notice] [pid 661] AH00163: Apache/2.4.38 (Debian) mod_fcgid/2.3.9 OpenSSL/1.1.1d configured -- resuming normal operations [Thu Oct 07 00:04:08.257512 2021] [core:notice] [pid 661] AH00094: Command line: '/usr/sbin/apache2' [Thu Oct 07 00:04:21.758504 2021] [mpm_prefork:error] [pid 661] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting [Thu Oct 07 00:12:48.362447 2021] [mpm_prefork:notice] [pid 661] AH00171: Graceful restart requested, doing restart double free or corruption (!prev)

If you won’t look at what I told you to look at, I can’t help you. You need to figure out which application is holding connections open for an unreasonable amount of time. I can’t do that for you.

Look at your process list. If you are using any reasonable execution mode (not mod_php), you will see processes owned by one or more of your domains. The one that has a lot of processes is the one with the problem app.

I don’t know what else to tell you. That’s how you troubleshoot this, if you won’t do it, I can’t help.

I had a look at the process Tree. Only apache start up.

mod_php is not active, only mod_perfork.

I stopped all docker container’s disabled the domain’s. But the same again.

I have a look next day. Must sleep.

What he’s telling you is to look at all the processes you have running to see which one or ones is using the most resources. There are a couple of ways to do that.

There’s actually a panel in Webmin that will list the processes running on your server, how much memory they’re using, how much processor, etc.

You can also go to your terminal and type: ps aux

That will give you a list of all the processes running on the system and is part of what Joe was telling you to look at. It looks like this:

You’ll be looking for an application using up lots of system resources and what user those processes belong to. You’ll probably find, as Joe mentioned, that one person/user has a ton of apps taking up a ton of resources.

That is what you’ll have to stop.

I undestand this. But there is nothing else running at this moment except apache. Same behaviour. Maybe i purge apache and install it again. And look what happens.

I purged apache2 and install it again. Is there complete list which mods must be installed?

No one suggested you do that, and it is a terrible idea. You’re making it impossible to help you.

1 Like

That is impossible.

I think i must make an new Setup. I have no idea whats happen Here