Apache won't start after server update

OS type and version Ubuntu Linux 20.04.4
Webmin version 1.991
Virtualmin version 7.0-4
Related packages Apache

Good day

One of the servers Apache won’t start. Tried looking for a solution on the thread but couldn’t find anything that’ll assist me.

When I type: “systemctl status apache2.service.” I receive this error:

AH00526: Syntax error on line 122 of /etc/apache2/sites-enabled/0-edu2moro.co.za.conf:
 Invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration

It occurred after I updated the virtualmin server.

1 Like

Faced the same issue an hour ago, you will need to edit the /etc/apache2/sites-enabled/0-edu2moro.co.za.conf and comment out/remove the line with ‘php_admin_value’


That is the same thing I was probably thinking @safiweb. I’ll make a backup then remove the line.

Thank you.

You have to do it in every domain, the error message just show the first domain. If you take just this one away, it will appear again in the next domain, just one at the time. So before you try to restart Apache, check all files in sites-enabled. But pay attention, it could be that you have to to it in sites-available instead. That how it was for me.


Thank you everyone. I managed to fix the problem with your guys help. Much appreciated.

1 Like

@PresPhuture THANK YOU for marking this as solution.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.