Apache Timeout Configuraton

OS type and version CentOS 7.9.2009
Virtualmin version 7.1

Hi everyone,
I’ve got a timeout issue when performing a certain task in the admin area of a website, that is hosted on a VPS running VirtualMin.

I have Remi PHP8.0 in FPM mode, and Apache 2.4.6.

The task I am trying to do is reasonably intensive, and it times out after 60 seconds, and displays a 503 service unavailable error in the browser.

In the apache web error log, I see this:

[Wed Jun 15 17:04:48.463462 2022] [proxy_fcgi:error] [pid 22998] (70007)The timeout specified has expired: [client IP_HERE] AH01075: Error dispatching request to :, referer: URL Here

The PID 22998 is owned by Apache and displays the following command when I view it: /usr/sbin/httpd -DFOREGROUND

I have looked, but I can’t for the life of my find the website script running time setting. I’ve got a Maximum PHP script run time I can configured in Server Configuration - PHP options, but this is set a lot higher than 60 seconds, so I’m thinking there must be an apache one I am missing somewhere.

Can anyone point me in the right direction?



Where did you go to adjust PHP settings?

  1. You may have edited the wrong settings making them useless.

  2. It could be a memory issue, where the process is being killed off.

If you’d like some support diagnosing and addressing the issue I can be contracted for an initial session at an affordable Virtualmin exclusive rate.

Let me know.

*** Affordable, Quality Virtualmin Assistance https://tpnassist.com ***

Hi, thanks for replying.

The PHP settings were adjusted in Service - PHP-FPM Configuration, and they added settings to my config file in: /etc/opt/remi/php80/php-fpm.d/16081968184171.conf

pm = dynamic
pm.max_children = 30
pm.start_servers = 15
pm.min_spare_servers = 10
pm.max_spare_servers = 15
php_admin_value[memory_limit] = 1024M
php_admin_value[upload_max_filesize] = 20M
php_admin_value[max_execution_time] = 1200
php_admin_value[max_input_time] = 2000
php_value[max_execution_time] = 2000

Ive added some extra config to my httpd.conf file as follows:

KeepAlive On
TimeOut 300
KeepAliveTimeout 300


Did you restart PHP-FPM afterwards?

I did, and Apache with the other changes i made


In the same section you added Timeout 300 try adding ProxyTimeout 300 then restart Apache.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.