Apache serves only default htdocs...

Hi all,

ok now that I seem to have fixed most of my DNS problems I just discovered that my Apache 2 installation seems to serve only the default HTDOCS directory?

Currently I have only one virtual domain installed wich I can SHH/FTP without any problem. I checked the forum already for an answer but no luck. Can anybody help me bugfixing this?

Thanks in advance…


This is almost certainly a mismatch in the NameVirtualHost and VirtualHost directives. There’s a bit of information about it in the Troubleshooting Common Problems guide here:


But it probably needs some further advice…this is a really common source of trouble. I’ve yet to figure out how folks end up with these mismatches. :wink:

Thanks Joe,

I read another post about this matter but was not sure where I had to change what. Anyway, I know now what I have to check, the trouble is that NameVirtualHost is already assigned to the same IP as my VirtualHost directives.

I tried to change Apaches Listen directives to:
Listen xxx.xxx.xxx.xxx:80
Listen xxx.xxx.xxx.xxx:443

… but then I can not start Apache at all:

Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Can’t assign requested address: make_sock: could not bind to address xxx.xxx.xxx.xxx:80 no listening sockets available, shutting down
Unable to open logs

I am sure I screwed up the Apache config somewhere. Even though I have not changed anything as far as remember. I am confident my DNS is alright since FTP and SSH is working quite well so far.

If I would send you the login details, would you mind having a brief look? At least to check if my setup is not completely crap. :wink:


ps: I also seem to have some issues with mail delivery but will come to that later.

Ok here is a little update…

I was able now to get this all a bit untangled I think. So, now I can access all virtual servers correctly. I used the public IP instead of the private one assigned by the DHCP router. Not sure why I did that in the first place!? :wink:

However Joe, I am still not 100% sure about my DNS setup. So if you don’t mind and find the time, I would really appreciate if you could have a look at this mess. :smiley: