Anyone else been able to get Vmin to go?

Hi people,
Have only had just one lone comment about Vmin success (AH) and he had some fun at first.
I am an extreme guru(NON) :frowning: and have been trying for a loooong time to get Vmin to go on my RentaServer with no success.

It appears from AH’s experience that I might have a chance after reformatting the HD and going to Fedora 5 via my Supplier.

Unfortunately, I have not been able to raise Joe for some weeks now to get some help with the re-install (no facility is available under my account re Serial numbers for D-I-Y download although I have a paid service.)

So, would anyone out there who has been able to make a Vmin install work, either GPL or Pro Version, care to offer some words of encouragement - if not advice, to a tyro?

I did work with CPanel/WHM for a few years, it’s dead simple to drive when not being cracked by scriptkiddies, but just can not figure out the mechanics of Webmin/Vmin.

I’m hoping all the problems were - as AH found - caused simply by installing over Webmin/VminGPL.

My Server Host did reload Webmin after the clean up and upgrade, but there is nothing there now to save. I can simply delete it and/or install Vmin again, but I’d sure like some advice and encouragement! :slight_smile:


Not sure I understand your question, but you should be able to get your install script here in one of the menus.
As for installing, I installed a minimal copy of FC5 and let the install script do the rest. I had to install php-mysql manually, but everything else went fine. After that go into the module config and server templates to config for your server and your done

Hey John,

Your install script is available for download just like everybody elses (I’ve pointed you to this link in the past):

You can also get there from the "Your Account" link–there is a "View and download your purchased products" link midway down the page. You can always download the install script for your licensed products from this page for the life of your license.

Actually, it seems that you’re logged into an account that has not purchased anything, which means you wouldn’t have access to the downloads. You’ll need to use the account you used to purchase the product. If you’ve forgotten the password for that account, you can click the “Forgot Password” link after entering the email address used to purchase the software. I don’t know what email address or account name you used to purchase the software, so I can’t transfer it for you to your new account. If for some reason you can no longer accept email at the address you originally used to signup (in order to reset your password for that account), let me know the old address so I can look it up and I’ll transfer your purchased products to the new account.

Hello Joe,
Jeez you are a hard man to reach these days! Maybe this is Tao (The Way) :slight_smile:

  1. No - you never pointed me there in the past. I just looked for it to use it in my mail system. Nothing there.
  2. Can’t see anything on the access from online either.
  3. I will try the follow up password option, but it would most likely have been a now-unavailable-address due to the fact that I’m off the air in Vmin these last months, remember?
    I never used the download facility, as you had kindly offered to and installed it for me at the time.

Unfortunately, your BBS Software only offers this message to each try-on address I put in:
It has been a giant pain trying to re-establish links with over a hundred people and having to embarrassingly use a generic Gmail account and this exercise is all too familiar now… (sigh) as all of my old addresses are non-functional.

Please check your inbox. Within the next few minutes, you should find a message from with instructions on login page.

I have received 3 changes all access my account but none access a downloadable file.

But do you mean your system doesn’t have the ability to track existent transactions??

It does look (hopefully) as though the problems were probably caused by the loading over the top of an existing instal.
I hope so.
Although not another soul has answered my request for support/ success info outside of "AH" , he DID get it to work.

So, here’s hoping still.



Hi Berkwood(sic),
THanks for replying!
My post to Joe explains my download problem along with his answer.
Odd that you had to install php-mysql manually,though.

I’m glad to hear that after that it all worked - I sure need the encouragement.

But it is a looong way from being an easy install for non-experts in my experience so far. But the promo READS great!

Like most wannabes out in the Cyberbog - I originally just wanted the sort of setup that WHM/Cpanel gives - without its "leaks". It DOES crack easily!

But I recently had to go back to CPanel for my odd clients leftover from two recent horror Server Supplier exercises and then never being able to get Vmin to work properly with imports.

Now, I only want to use Webmin/Vmin for a single owner account. The appeal being security and the program installer function and as per the demo example, to put on added Domains from time-to-time, EASILY.

I am hoping that the weakness/bug in the install function of installing over a prior free install can be fixed by my having had a complete clean re-install of Fedora 5 and starting from scratch, as "AH " did.



Hi Joe,
No result from trying old email addresses - those still reachable had no effect.
No product display.

I have my older material archived on a separate disk which is a lot of work for a physical re-install and go looking for the data.
But, surely your accounts system should be able to easily look up a transaction record/history for Fablor?

If not, you really need a new/better one! :slight_smile:

HOWEVER, a simpler solution would be if you could repeat the original exercise and simply install it for me again… pretty please? :slight_smile:



Hey John,

But, surely your accounts system should be able to easily look up a transaction record/history for Fablor?

Sure, it’s easy, and I’ve volunteered to look it up all along. But it only works once I know what name I’m looking for (which is why I asked for it twice). This is the first mention of “fablor” in this thread. The only system that seems to be broken here is the one that I use to request further information…I’ll get right to work on that. :wink:

Ok…that said, you don’t have an account with the word “fablor” in it, either:

for users matching the criterion:

* Email contains 'fablor'
*  No users found.

for users matching the criterion:

* Last name starts with 'fablor'

* No users found.

for users matching the criterion:

* First names contain 'fablor'

* No users found.

So, I can lookup users on with no problem, and I can lookup purchases using’s reporting tools, and I can easily cross-reference between the two, but I’ve got to have something to go on. We currently have 2,239 registered users, and a few hundred orders at…finding a specific one when I don’t know any detail of the account is not feasible. I’ve already performed the same three searches for “rigby” with no results.

Really, I’m happy to help you get your account straightened out, but I need something to go on here. I’d love to know everyone on a first name basis (and I try to remember everyone that we deal with, and the specific problems they’ve run into, and such), but the reality of the commodity software business is that we have to make an average of one or two sales every single day in order to just pay the bills and keep ourselves in food/shelter, and we’ve been selling for nearly ten months now at not quite that pace, but close enough…that adds up to a lot of names. We’re trying to offer very personal service, and I’ll perform another installation for you; but no matter how much I’d like to, I can’t read your mind to find out what name or email address you purchased your software under.

Hi Joe,
Just went thru the exercise of PayPal’s security to get access - due to my now dead/unavailable key-domains - and went looking for our transaction.
After all o’that: No listing!

Rechecking this a.m., I see you mentioned - who allow no access by end purchasers without details.

I tried to again access “my” account on your BBS but it won’t allow a login as anything else but via my desperate Gmail thing. Irrespective of what email address I try, it defaults to the very unhelpful for now, gmail address, as an error.
I was trying for instance to login as email at:, another remote purchase possibility.

It appears that I made the purchase via and have no confirmation so far that I can find via that name on my system. ( It is customary to send an email advisory confirming transactions.)

Due to online banking rules (over 90 days) - from here I would have to request a paper trail based on Statement date from my Banks here in Oz, which is a long process.

I can’t understand why my intrinsic details can’t be found on Authorize net, or your own system. We have exchanged more email traffic due to the problems of getting Vmin to go than to any other commercial account I have.
(As said numerous times before, I really appreciated your efforts and it is why I have persisted with Vmin)

But something is wrong somewhere. 90% of my transactions are as Fablor and my name is mentioned in 100% of them for contact details, where Credit Card transactions are involved.

What if it never happened/completed at all???


(I do think that this exchange should be off the BB, but I can’t seem to reach you readily on email???)

Hey John,

Now we’re getting somewhere:

for name or email matching ""

Show | Hide unapproved users.

* Philkin Philkin (

You do exist after all, and this user does have purchased software.

It appears that I made the purchase via and have no confirmation so far that I can find via that name on my system. ( It is customary to send an email advisory confirming transactions.)

Of course. We always send out an email receipt along with the transaction summary at time of purchase.

(I do think that this exchange should be off the BB, but I can’t seem to reach you readily on email???)

The Customer Issue tracker is actually where this kind of thing should take place–it allows us to close issues when they’re done (and they stick around until resolved so no one forgets about them). Obviously, since neither forum nor issue tracker are private, private data should never be posted to either. We’ll get the customer issue tracker working better, as soon as possible (unfortunately, no one seems to understand the code, including OpenACS core developers…so I’ve been unable to find anyone who can customize it for us, so far).

Hi Joe,

Funny, just sent you a post via email and came here to give you a "heads up" that I sent it.
Took me most of my day to re-install and find it on my old System.
It contains all those details… (sigh)

Look forward to next lot of good news!


(Philkin -Admin name)

Hi Joe,
Since your last offer to help me get it setup yetagain, I’ve had to have a go at it myself ( its been a long coupla months since your offer and my grateful acceptance - time flies when you are having fun, but our anniversary since the very first try is only a few months away).

Well, it trashed again. Didn’t even get to the install phase.
I’ve posted the details here above, but this note is just to keep up the odd flow of data.

I DID try to use the docs - but they aren’t for Users. E.G. I THINK you might have to have a functioning domain name before Vmin will install? (Kinda defeats the purpose?)
However, I could not find any way in Webmin docs to actually install Domain names anyway…


John Rigby Netcapitalisation, FABLOR et al

Hey John,

The offer still stands, but you’ve gotta email me how to login to your box. I know I’ve had the information in the past, but I don’t generally store those kinds of details about customers servers.

Oh, yeah, on this one:

I DID try to use the docs - but they aren’t for Users. E.G. I THINK you might have to have a functioning domain name before Vmin will install? (Kinda defeats the purpose?)

Understandable confusion, though it’s pretty normal for the hosting provider to setup a hostname on the box. It’s pretty rare for folks not to have a hostname for the system before installing. And it doesn’t have to be a functioning domain (in fact, it probably shouldn’t be, since it’s nicer to have all domains under the control of Virtualmin)…it just need to be a fully qualified hostname, which is a wholly different issue altogether. I’ve documented in the other thread how to set the hostname on a box that doesn’t have one (note also that most operating systems allow you to set the hostname during installation), it’s pretty simple–two steps. Run “hostname” and edit /etc/hosts.

I’ll add some code to to set this up for you, if a fully qualified hostname is not found during installation.