Another attempt at LE wildcards

Webmin version: 1.940
Virtualmin version 6.08
CentOS Linux 7.7.1908
Apache webserver

Not having had any success at Let’s Encrypt wildcard generation, I had hoped things might be different with Webmin v1.940

  • Recently upgraded to Webmin v1.940
  • Installed certbot with
yum install certbot
  • Enabled Apache SSL website
  • Using ‘Virtualmin > Server Configuration > SSL Certificate > Let’s Encrypt’ I successfully created a LE cert for
  • then, attempting to create a wildcard LE cert for

fails with this message:

Failed to request certificate : Output did not contain a PEM path!

Any idea what I’m doing wrong?

edit: added path to Lets Encrypt module


This part:


Replace this with:

I expected this issue to happen, and we already added it on dev version, and next Virtualmin release will have a simple checkbox to let user to query wildcard certs.

I had tried


So close! Switched them around as per your instruction and it appears to have worked. I’ll create an alias/sub-domain to check all’s well.

Thank you so much.

Thank you so much.

Our pleasure.