andreychek: Thank you

I had to reinstall my VPS server software (Debian 7) today. I did an update and an ugrade, then installed Virtualmin, same as the first time. The installation went good. No issues. I uploaded my site to the public_html dir and tried to load my index page. Surprisingly though, it loaded the index page from the /var/www/ instead of /home/my_site/public_html/. I have looked at everything! I went so far as to reinstall Debian again on my VPS and install Virualmin again following:

Not sure id this means anything, but the folders usermin and webmin are installed in the /var/ dir, and the foldr webalizer installed in /var/www/. Not sure if they installed here last week…or if this is even helpful.

I don’t what to do, what to change. This is so crazy. I mean, it was working until I reinstalled it.

I’m open to ideas and suggestions. I really like this software, but I don’t think it likes me very much. I uploaded a few screenshots, mainly because none of them reflect my ‘real’ IP address of

Please help an old man out, guys.


Links to pics as they failed to upload here. I apologize for any inconvenience:

After doing a little reading, I’ve concluded that Virtualmin isn’t what I was wanting in the first place. I’m running just my one site on my VPS and installed Virtualmin because of the mail capability. But Webmin seems geared more toward what I need, plus I believe it offers a mail system through Sendmail. I may be wrong, but I’m tired of installing my server software and Virtualmin over and over.

You guys are great, btw. Although answers may come in a little slowly, they are always from folks who take their time to offer good answers. And that goes a long way in this world.

Webmin, here I come.

Thanks to all,


I wanted to mention that if you perform a Virtualmin installation using the, you also get Webmin. And you can use Sendmail with both Webmin and Virtualmin.

However, if Webmin is what you need, that’s fantastic, there’s nothing wrong with using just that.



Just my two cents, Virtualmin is a module built for Webmin which offers web hosting providers an easy way to setup and manage virtually everything required including: databases, dns, email, and websites.

Because Virtualmin is built on top of Webmin, technically everything that Virtualmin can do could be accomplished through Webmin itself, just there will be more manual steps which will need to be taken to accomplish many tasks, which is why installing Virtualmin is generally preferred as it makes things simpler and less error prone.


Best Regards, Peter Knowles TPN Solutions

Phone: 604-782-9342
Skype: tpnsupport


My one problem with Virtualmin was that, once i reinstalled my server sofrtware and Virtualmin and uploaded my site to the public_html directory, nothing worked the way it did the first time around. That is to say that my domain wasn’t loading. Instead, the index.html in /var/www/ of my VPS was loading. I reinstalled Debian 7 and Virtualmin four times yesterday, thinking maybe something went wrong with the installations. But each time the only page that was loading was /var/www/index.html, not my site that in the public_html dir.

Persoanally, I liked the heck out of the Virtualmin interface. Very intuitive, slick. But I just cldn’t make it work after the reinstall. Please view the screenshots from the links in my earlier post. Maybe that shows something that’s set wrong. I have no idea. Or…I’ll give you my credentials and you can try to install it =) Let me know.

Thanks again,

This sounds like the VirtualHost configuration is wrong in a way that prevents name-based hosts from working. I believe there was an issue with newer Debian and Ubuntu releases that included some sort of different VirtualHost configuration thing (maybe *:80, or something, that sucked up all requests). But, I thought we were automatically correcting that during install.

Maybe Eric remembers more about that issue and whether the fix is actually happening?

I don’t use Debian/Ubuntu myself (I develop on Fedora and deploy our sites on CentOS and Scientific Linux), but Eric and Jamie do. I’m surprised this would still be around for such a long time…unless it’s some kind of regression. But, maybe it’s also something completely different. I dunno, as it’s not an issue I’ve seen.


I’m curious if these two commands resolve the issue for you:

a2dissite default service apache2 reload

Hello andreychek:

I ran the commands and /var/www/index.html default page is still showing up.

Just a few minutes ago, I reinstalled Debian 7 and Virtualmin again. My site is in the public_html directory where it is suppose to be. But for some strange reason that’s eluded me for two days now, I can’t pull any of those pages up. The default index.html from the Debian installation is being shown instead.

Let me tell you: I installed Debian 7 so I wld have a fresh server software install for Virtualmin. Then I did and update and an upgrade. Then I ran for Virtualmin. All went well. I logged in to the panel and went through the initial setup process. I did get this one thing when I re-checked the configuration though:

“Default IP address is set to, but the detected external address is actually This is typically the result of being behind a NAT firewall, and should be corrected on the module configuration page.”

I use Ramnode VPS and am not behind any kind of firewall.

I just don’t know what to do. I will happily give you my login credentials so you can see what you can see. I don’t mind that at all. Thing is, I’d like to get this going so I can move on to other things related to my site.

Please advise.



Thank you for responding. I just sent new info in another post to andreychek. Maybe what I said there will help you help me.


I think I fixed it. I think.

Under Addresses and Networking–>Change IP Adresses, I changed to my true IP. And now my pages load.

But why did I have to do that? I messed with no configuration at all. Everything configured was done during install by Virtualmin.

Please advise…and thank all of you for your help/input. You’re a great bunch here.


UPDATE: This is really crazy, but the IP changed back to…yet my site still comes up properly. Someone else try it =)

Works from my part of the world.

Is your system getting its IP from DHCP? It’ll change whenever DHCP is renewed. Though is sort of nonsensical, as that’s a loopback address (but not even the standard loopback address).

Hello Joe:

No, my IP is static. It never changes. But with regards to the funny loopback, I just wish one of you would log in to my Virtualmin and take a look around and fix what’s not configured right. Everything you’ll see is from the Virtualmin installation. The one change I made last night, issuing my correct IP, was instantly changed back by Virtualmin to the loopback. And even though my site shows now, there’s still something wrong with how Virtualmin set up.

Please advise.



Hmm, that sounds unusual!

Webmin and Virtualmin wouldn’t actually change your settings, unless it’s told to do so.

If your network settings and/or IP addresses are changing, it sounds like something else may be going on.

What is the output of these commands:

/sbin/ifconfig cat /etc/network/interfaces grep -i '<virtualhost' /etc/apache2/sites-enabled/*.conf

Here you are, andreychek:

I put everything here in a code block but it kept disappearing. The link above will show you the results of your commandline requests.

Thanks for your help.



Thanks for all the output.

If you look in System Settings -> Virtualmin Config -> Network Settings, what is “Network interface for virtual addresses” and “Default virtual server IPv4 address” set to?

I’m wondering if perhaps it’s not set to look at your public IP address.


Hi Eric,

Network interface for virtual addresses: venet0

Default virtual server IP address: From network interface

I’m on day two, Eric, and since i made that one IP change (that was instantly changed back to, I’ve had no issues. However, when I Re-check Configuration, I still have this:

“Default IP address is set to, but the detected external address is actually This is typically the result of being behind a NAT firewall, and should be corrected on the module configuration page.”

Again, I’m behind no firewall.

Please see full description at:

I hope all of this helps. And I greatly appreciate your concern. Thank you.



Okay, so in the Network Settings screen, the default network interface is set to “venet0”.

What we learned when running “/sbin/ifconfig” is that venet0 has the IP address “”.

So the output Virtualmin is producing there makes sense, as it’s currently configured to use an internal IP address, not your public address.

What I’d recommend is to go into System Settings -> Virtualmin Config -> Network Settings, and to set “Network interface for virtual addresses” to “venet0:0”. Your ifconfig output shows that the IP address associated with “venet0:0” is actually “”, which is your public IP address.

Once you make that change, I suspect the Re-Check Config output there will appear correct.


Hello Eric:

I made the change. Now I have this:

Using network interface venet0:0 for virtual IPs.

IPv6 addresses are available, using interface venet0:0.

Default IPv4 address for virtual servers is

Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the module configuration page.

Default IP address is set to, which matches the detected external address.

To see the whole page, please view:

I don’t know if the IPv6 is an issue or not. Please advise.



Yup, it sounds like that is working well! There’s no need to do anything with the IPv6 addresses, unless those are something you need. However, most folks don’t use those.


Thank you for all your help, Eric. You’re a scholar and a gentleman, sir. I’ve been taught a lot about Virtualmin over these past few days by you and others who took the time to mess with and old geezer like me. Kudos to you all. A really great community here!