Amazon S3 backup stopped working after yestarday's update


I use Ubuntu 18.04.02 with all updates and latest Virtualmin etc.

I installed some updates yesterday:

python3-lib2to3 (3.6.8-1~18.04) over (3.6.7-1~18.04)
python3.6 (3.6.8-1~18.04.1) over (3.6.7-1~18.04)
libpython3.6-stdlib:amd64 (3.6.8-1~18.04.1) over (3.6.7-1~18.04)
python3-distutils (3.6.8-1~18.04) over (3.6.7-1~18.04)
libssl1.1:amd64 (1.1.1-1ubuntu2.1~18.04.1) over (1.1.0g-2ubuntu4.3)
python3.6-minimal (3.6.8-1~18.04.1) over (3.6.7-1~18.04)
libpython3.6-minimal:amd64 (3.6.8-1~18.04.1) over (3.6.7-1~18.04)
libelf1:amd64 (0.170-0.4ubuntu0.1) over (0.170-0.4)
libglib2.0-0:amd64 (2.56.4-0ubuntu0.18.04.3) over (2.56.4-0ubuntu0.18.04.2)
libglib2.0-data (2.56.4-0ubuntu0.18.04.3) over (2.56.4-0ubuntu0.18.04.2)
openssl (1.1.1-1ubuntu2.1~18.04.1) over (1.1.0g-2ubuntu4.3)
libwww-perl (6.31-1ubuntu0.1) over (6.31-1)
libnet-ssleay-perl (1.84-1ubuntu0.1) over (1.84-1build1)
libio-socket-ssl-perl (2.060-3~ubuntu18.04.1) over (2.056-1)
libruby2.5:amd64 (2.5.1-1ubuntu1.4) over (2.5.1-1ubuntu1.2)
ruby2.5 (2.5.1-1ubuntu1.4) over (2.5.1-1ubuntu1.2)
ruby2.5-doc (2.5.1-1ubuntu1.4) over (2.5.1-1ubuntu1.2)
python2.7 (2.7.15-4ubuntu4~18.04) over (2.7.15~rc1-1ubuntu0.1)
libpython2.7-stdlib:amd64 (2.7.15-4ubuntu4~18.04) over (2.7.15~rc1-1ubuntu0.1)
python2.7-minimal (2.7.15-4ubuntu4~18.04) over (2.7.15~rc1-1ubuntu0.1)
libpython2.7-minimal:amd64 (2.7.15-4ubuntu4~18.04) over (2.7.15~rc1-1ubuntu0.1)

One of these brakes Amazon S3 backup, any idea how to fix, test etc?

Error on the S3 backup (frontend):
Uploading archive to Amazon’s S3 service …
… upload failed! Empty response to HTTP request. Headers were :

Just to report we see something similar on 18.04.2 after the update but only on one out of 4 virtual servers on the same machine on a Full daily backup. The one that failed .tar.gz is normally around 800MB, the ones that succeeded were small <5MB. Tried increasing “Number of times to re-try FTP or S3 uploads” to 10 and still the same “Empty response” error

Update: On checking our installation, found that this particular server didn’t actually have the aws client installed.
Installed awscli with pip and set the path via System Settings > Virtualmin Configuration > Backup and restore.

The problem virtual server is now uploading successfully to S3.

well… in my case all packages were installed and were there before, it stopped working after the above updates…