After updates run I cannot install scripts MySQL errors

Ubuntu Linux 20.04.2

I have Webmin with 2 virtualmin sites.
These are self-learning and testing, not production server.

I ran available updates, and everything appeared normal and functional except an opencart script I had on:
I was getting Mysql errors on trying to get to page.

I deleted the opencart and tried several other scripts and they all fail as well.

Can someone give me steps and info to post that would be needful to help me fix issue?
I think it is something that changed with configuration or location of MySQL configuration or installation files because every installation fails due to something with MySQL.

Most or all scripts tried so far give me error: Failed to install script : DBI connect failed : Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)
as listed below.

I cannot start or view database settings as I get the same error.

Downloading (162 bytes) ..

Downloading (16.08 MiB) …
Received 15.61 KiB (0 %)
Received 1.6 MiB (10 %)
Received 3.21 MiB (20 %)
Received 4.82 MiB (30 %)
Received 6.43 MiB (40 %)
Received 8.04 MiB (50 %)
Received 9.65 MiB (60 %)
Received 11.26 MiB (70 %)
Received 12.86 MiB (80 %)
Received 14.47 MiB (90 %)
Received 16.08 MiB (100 %)
… download complete.

Configuring webserver PHP settings …
… already done.
Now installing WordPress version 5.7.1 …
Failed to install script : DBI connect failed : Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)

This issue was fixed doing a full re-install of VPS, Virtualmin and full rebuild. It was a test/training VPS and I did not have proper backups for any restores.

For any future readers, this was a MySQL troubleshooting question. To fix it you would have needed to figure out why MySQL wasn’t running, and get it running. Usually something simple, but it’s complicated software, so lots of possibilities.

Restarting the mysql (or mariadb) service would have been the first step, then checking logs, etc.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.