after php 5.4 installed fast cgi is throwing error (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI ser

Hi Everyone

I am running a Server with virtualmin. As i have installed php 5.4 on the debian squeeze server, i getting on every page a 500 internal server error. IN apache error log i see why.

“(104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server” is thrown but i don’t know why?

anyone had the same problem / can help?



Hmm, that’s unfortunately not a very helpful error that it’s throwing.

What if you go into Server Configuration -> Website Options, and change the PHP Execution Mode to “CGI”… does that make a difference?


I recently had a routine (or so I thought) update of php from 5.3.25 to .26 from the Atomic repo. It caused similar issues and massive headaches for me on our production server. Apache 2 fails after update to php 5.3.26 or 5.4 .

Apparently it is due to a change to using something like set handler to make php more secure. Unfortunately the update seems to break loads of things on my server at least. I am not a programmer and only have a basic understanding of such matters so this update caused immense issues.

This is the link to where the issue is discussed as I have noticed many similar posts with what I think is the same basic cause but many symptoms.

I tried various fixes and was about to reinstall apache even and I then found out from this thread how to make the change from cgi to apache mode in Virtualmin.

The good news is that it worked for me at least so I can now breathe again after twenty hours of pain over father day and this morning! :slight_smile:

I have posted this hear as the above post helped me find where to make the change to test if that was the issue but it may well apply to many other scenarios not yet diagnosed as being caused by this update. Hopefully it will give people a workaround or at least some clues as where to look.

unfortunately not, when i run it in CGI instead if Fast CGI there is the same error …