Additional domain(vhost) Webmin not working

**Operating system:Linux
**OS version:CentOS Linux 8.2.2004

Hi, my problem is so simple yet so anoying. I have registered an vps in ovh, so i have the default domain given by ovh, lets say example.vps.ovh.net.novalocal. Now i want to add an additional domain(or virtual server like its called in virtualmin) so i can have another web page on example2.vps.ovh.net OR example1.example.vps.ovh.net(i dont know which is correct, but i have tried with everything).
All using the same ip address. Is this possible?
When i browse the example1 domain(example1.example.vps.ovh.net) it just cant find the ip address, but the DNS should be well setup by virtualmin automatically.
I have done it multiple times with different setups, following step by step guides and i dont find yet any scenario problem like mine yet it should be so common.
Any help is very welcome, thanks in advance.

The ovh domain does not belong to you and is not under your control, so you cannot use the domains that you have specified above.

If you register a domain name then it will belong to you and will be under your control. You could then create virtual servers in Virtualmin and configure your domain(s) DNS or ‘A record’ to point to virtualmin so that your domains show web pages that you have uploaded to Virtualmin.

Ok i understand now, i’ll register a new domain then. I guess once registered i can delete the two virtual host(the one preconfigured and the subdomain i created) and create a new pointing to my domain, isnt it?

Anyway the problem is very much solved for me, thank you!