Add a CNAME record to the DNS configuration of my domain name?

Hi Virtualmin,
nice software, but still getting used to what Virtualmin, Webmin and Usermin are?
Anyways, just trying to add Google analytics and they tell me to add a CNAME record to the DNS configuration of my Domain host.
I don’t have any DNS services with my DNS host as Google analytics instructs. I can run everything on Virtualmin/Webmin.

So where and how can I add a CNAME record to make this work? I found this post, but the navigation path isn’t right.

My specifications are: (Navigation path…Virtualmin/System Information)
Webmin version 1.600.
Theme version 8.5.
Kernel and CPU Linux 2.6.32-279.14.1.el6.i686 on i686.
Operating system CentOS Linux 6.3.
Virtualmin version 3.96.gpl GPL.


What is the nameserver for the domain you’re using? Is that your Virtualmin server, or is that at a third party provider?

If it’s your Virtualmin server, you can add a CNAME record by going into Server Configuration -> DNS Records, and in there, you can add a new CNAME record.

That will only work if your Virtualmin server is the nameserver for your domain though.


Yeah, the information in that post you linked is outdated, since it’s over 2 years old. :slight_smile: Eric named the place where you can configure DNS records now in Virtualmin.

Also, if you want/need to go low-level, you can use Webmin’s BIND module too to edit zones, which has more options and will not interfere with Virtualmin’s edit function.

Thanks, that navigation path worked.
Now just need Google analytics to verify. Posted help to Google as not verifying.

Well, no reply from Google forums on why the TXT or CNAME records won’t verify the domain with Google Analytics?

I go to Virtualmin > Server Configuration > DNS Records > Create Record of Type: TXT - Text > Record name: Same as domain > Record type: TXT - Text > Cache time: Domain default > Text record: google-site-verification… > Record comment: Google analytics > Create.

I also go to Virtualmin > Server Configuration > DNS Records > Create Record of Type: CNAME - Name Alias > Record name: > Record type: CNAME - Name Alias > Cache time: Domain default > Target DNS name: (details provided by Google analytics) > Record comment: Google analytics > Create.

The error keeps coming up: We weren’t able to verify your domain:
Verification failed for using the DNS TXT record method (less than a minute ago). The connection to your server timed out.


Drop me an email to:

Let’s get this bad boy put to rest. Should be able to solve the issue in a few moments over a screen sharing session :slight_smile:

I’ll be up and ready for a few more hours :slight_smile:


example your server ip is then go to your domain’s control panel and register & with that MAIN ip of your server.

Then set the nameservers of your domain to, this way gives you private nameservers, and you’re not using ISP’s.

Then in vitualmin you create the domain. Once created

go to Virtualmin > Server Configuration > DNS Records > Create Record of your choice.

Good luck