Account migration: Fatal error - Failed to create temp directory

Operating System: CentOS Linux 7 (Core)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 3.10.0-1160.11.1.el7.x86_64
Architecture: x86-64

Loving virtualmin so far but have hit a problem as I’m getting an error with the GUI for webmin.

Background - I tried to migrate an account but got lots of errors along the lines of

- Cannot mkdir: No space left on device`

I followed the advice of a thread which suggested going into

Webmin -> Webmin Configuration -> Advanced Options, and setting “Temporary files directory” from /tmp to /var/tmp

After this my webmin install is just a blank white screen with

Untitled

I’ve tried logging in again in incognito mode - the login screen is fine but I’m getting the same white screen after login.

I’ve tried restarting webmin and the server, but it doesn’t make any difference. I suppose I’d ideally like to just roll back this change. Perhaps there is a config file I can edit?

The sites etc load fine, it’s just webmin gui which is throwing an error

Thanks in advance for your help.

also as an aside the link to ‘Documentation Wiki’ in the left hand menu on Webmin is currently broken.

Hello @rm1 and welcome to the community.

And how exactly did you go about doing that? Did you use Virtualmin -> Backup & Restore or did you use Virtualmin -> Add Servers -> Migrate Virtual Server?

Kindly describe where you are migrating from: another Virtualmin system or some other server managed by some other control panel? I think you might be barking up the wrong tree by changing the location of tmp.

1 Like

Thanks for the welcome and your kind help @calport :slight_smile:

I was using the Virtualmin -> Add Servers -> Migrate Virtual Server feature.

(reposted as I apparently have 2 accounts here!)

Webmin documentation has been fixed (it was a rewrite bug, all direct links worked, but that one specific link didn’t match either of the rewrite rules).

3 Likes

I have also patched the theme to prevent printing theme footer, if theme header failed, so there will only be an error message printed.

1 Like

Just to update on this in case anyone hits the same problem, I fixed this by

  • logged in via SSH
  • created a new folder at /var/tmp2
  • opened /etc/webmin/config
  • changed the value of tempdir
  • rebooted the server

Now things seem to be working again.

1 Like