Access Virtualmin Email from Windows 10 Client

So email works. I can email contact@domain.com and if i log into Usermin i can see the email in there.

When user tries to log into Windows 10 mail client, chose Other, puts in email and password, it says “We couldn’t find your settings.”

have you got this set ?


access at virtualmin->Email Settings->Mail Client Configuration

Thanks. It was set to no. I set it to yes but still no luck.

That’s odd perhaps there is something in the server templates that has stopped it working … TBF I gave up on this long ago and just set up the Outlook/ windows mail clients manually when I need to

If DNS for your domain is not being handled by Virtualmin then you need to manually add the autoconfigure DNS records to the domain for this to work.

@jimr1 has pointed you in the right direction.

1 Like

Could you elaborate? I am using AWS Lightsail for my instance and Cloudflare for my domain’s DNS. I have the MX records. Email is able to be sent and received. I just cant sign into the email address (contact@domain.com) via the Windows Mail client.

It is perhaps not correct to say that you cannot sign in. From what I can understand, you don’t want to or have not tried to manually configure the Windows Mail client; if you manually configure a mail client with the correct settings, it will work just fine.

What you then want is for mail clients to be autoconfigured and you invoked Virtualmin → Email Settings → Mail Client Configuration to that end . If you were using Virtualmin’s DNS then this is the only step you would need to take but you are using Cloudflare so you must take additional steps, naturally.

If you subscribe to Virtualmin Pro, you get Cloudflare as one of the DNS providers and you need take no additional steps to manage DNS records. However, If you wish to continue with Virtualmin GPL, you need to keep synced the DNS records in Virtualmin’s DNS with the records in Cloudflare.

Also see @MrPete’s addendum.

How to get nginx to support Mail AutoConfigure (or any other cgi-bin scripts)

So I am looking at DNS on both cloudflare and Virtualmin BindDNS…on Bind, im looked at the records file and i see records in there that I do not have on Cloudflare.

I am just trying to figure out how it all works. But it looks like Bind is making all the needed entries, so i just need to reflect them in Cloudflare? (where im guessing VMPro does it automatically through the cloudflare Api?)

Yes, Virtualmin has put in its instance of BIND all the correct DNS records. If you are using a third party DNS server then it is up to you to make the DNS records of Virtualmin’s DNS records reflect on the third party DNS server.

I have not used this feature, could someone else confirm?

1 Like

Thanks. Just having to look and learn at Virtualmin properly to see what needs to be done. This has been a learning adventure for sure. Ill make these entries and let you know.

So Thunderbird works fine. Its just the Windows Mail client that isnt auto configuring

found this, this may help or not
https://roll.urown.net/server/mail/autoconfig.html

1 Like