Access Control doesn't work for nginx

Operating system: Ubuntu
OS version: 20.04

I don’t get Access Control to work with Nginx.
I clicked it directly in the VirtualHost setting and setup a User and an Password.

But the Page (means if I open “mydomain.tld” in the Browser) never shows an Password-Dialog if I enter the Page.
Any Idea what’s the cause of this issue?

I got it.
You must set “Basic authentication realm” to “Realm named”, otherwise the auth_basic Flag won’t be set in the nginx-config… and the password-request won’t ever executed.

BTW: Would be nice to have an “reload nginx”-Button directly in the screen after saving the Access Control settings. Else it’s round about 4 clicks away in another section to reload nginx and make changes take effect.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.