A lot of processes are created

Operating system: Ubuntu
OS version: 20.04 x64
RAM: 16 Ggb
HDD: SSD Samsung - 500 Ggb.

Problem with Virtualmin
A lot of processes are created with the name:/usr/bin/perl /usr/share/webmin/miniserv.pl /etc/webmin/miniserv.conf

When the value of 330-370 running processes is reached, Webmin is completely disabled in the system, and Virtualmin is only helped by restarting from SSH.
But after 5-10 minutes, the system freezes again from a large number of processes: /usr/bin/perl /usr/share/webmin/miniserv.pl /etc/webmin/miniserv.conf

How to fix it?

Everything works smoothly on the VM

Sorry for the bad English

No one can help???

We need more info, @VitaliyFT.

Is this a new install of Virtualmin (you have posted in the forums for the first time, so I ask) or has this problem emerged in an old install of Virtualmin which has been running normally for a time?

What has triggered this? Have you enabled a feature in Virtualmin / Webmin which will cause it to spawn many processes? Do you see lots of unexpected entries in your Scheduled Cron Jobs screen?

All I can say for certain is that Virtualmin comes with sensible defaults and the behaviour you describe can only be caused by your having set a parameter which causes Virtualmin / Webmin to do lots of things repeatedly in the background: managing messages in your mailboxes, for example.

This is a clean install of the operating system and Virtualmin. Only applications from the Virtualmin installation script are installed.

I get that: miniserv.pl is Virtualmin / Webmin so it is clear that the resources are not being consumed by any other script.

All questions in my previous message pertain to settings and configuration parametres that you may have applied. After installing Virtualmin, have you changed or tweaked any settings which may trigger multiple processes?

Additionally, if you care to answer each question that I have posted in my previous message, it will help me and others in the community help you more effectively.

MySQL 8.0 was removed. MariaDB was Installed and several versions of php 7.0, 7.1, 7.4 were installed.no more actions were applied.

Everything works fine in VMware Workstation Pro. On a real machine, this is problem.

Hmm. The plot thickens.

Your original statement quoted above does not hold true if you have removed MySQL 8.0 and added MariaDB along with several versions of php 7.0, 7.1, 7.4.

1 Like

??? :hot_face:

Here’s what the Webmin log shows

[16/Nov/2020:05:41:12 +0300] [192.168.100.5] Timeout : Waited for 290 seconds for start of headers
too many children (51 > 50)
too many children (51 > 50)
too many children (51 > 50)
too many children (51 > 50)
too many children (51 > 50)
too many children (51 > 50)
too many children (51 > 50)
too many children (51 > 50)

It looks like developers don’t visit the forum.
And the ticket system doesn’t work.
My problem still remains.

Yup.

And don’t tell anyone but all the users who post messages here are actually bots.

I can vouch for @calport he is not a bot, guaranteed. :wink:

There was an issue with Webmin 1.960 or 1.961 which created a lot of collectinfo.pl processes. And that is now fixed with Webmin 1.962
Refer https://www.virtualmin.com/comment/830418#comment-830418
Just check whether your issues is also related to that.

After upgrading: Apache 2-issues a lot of its own processes, despite the fact that the activity is only on one site. (reaches up to 500 Apache 2 processes) Very large number of processes /usr/bin/perl /usr/share/webmin/miniserv.pl /etc/webmin/miniserv. conf - which really slows down Virtualmin.

Summary

Installed from the “Install scripts” section - PhpMyAdmin and it starts working with errors. Or maybe I’m doing something wrong?

Dunno how far you got in the setup, but…

Did you configure phpmyadmin to work with the credentials of the mysql server…?

You are given a password to mysql on initial setup, if you forgot it you can change it.

I havent setup any guest server yet, but since that is rather early in the overall setup process it may be easy to miss.

The question is not about the password and its change. The problem is that phpmyadmin works with errors. And I didn’t find a solution to these errors. When entering the user’s username and password, everything works fine, but these errors are a little annoying for me.

Well,lets take the errors (?)…

Login without password is a default setting, you just can’t. You have to have a pwd.

The two additional errors seems to indicate you may have issues connecting to the mysql server. Is it locally or somewhere else?

Invision Community Suite talks about errors but not critical errors. Installed MySQL server MariaDB 10.5. before installing virtualmin (only used webmin), there were no such errors. If you paid attention to the screenshots, the user’s login field is duplicated in phpmyadmin on the login page. There are suspicions that these are php errors but neither as not MySql server.