Zone contains NSEC records. Use -u to update to NSEC3

Got an out of the blue error on the main virtualmin page about dnssec expiring which shouldn’t be as it’s set to resign itself like normal. Tried manually and got the following error:

Failed to re-sign zone : Re-signing failed : dnssec-signzone: warning: /var/lib/bind/mydomain.hosts:57: signature has expired dnssec-signzone: fatal: Zone contains NSEC records. Use -u to update to NSEC3.

Operating system Ubuntu Linux 20.04.4
Webmin version 1.990
Usermin version 1.834
BIND version 9.16

Appears it wants something upgraded related to either Bind or DNSSEC but as the panel function is controlled by virtualmin/wemin not sure what to do here.

1 Like

This is a known issue of Webmin 1.990, downgrade to the previous version. There is another topic in this forum about this. Search function is your friend. :wink:

Sorry about that, we will fix this in upcoming Webmin 1.991 shortly.

I just deleted and reset DNSSEC for that domain which worked fine.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.