ZenPhoto installation broken(?)


I’m using the latest Virtualmin Pro on Ubuntu 8.04. I installed ZenPhoto using the script installer, but the installation is broken. It looks like it doesn’t load any JS or CSS. Here’s what I spotted from the index page’s source:

<script type="text/javascript" src="//zp-core/js/js-string-constants.js.php"></script>
<script type="text/javascript" src="//zp-core/js/ajax.js"></script>

<script type="text/javascript" src="//zp-core/js/scripts-common.js"></script>
<script type="text/javascript" src="//zp-core/js/jquery.js"></script>

<script type="text/javascript" src="//zp-core/plugins/flowplayer/jquery.flashembed.pack.js"></script>
<script type="text/javascript" src="http://galtest.somedomain.org//zp-core/plugins/rating/rating.js"></script>
<link rel="stylesheet" href="http://galtest.somedomain.org//zp-core/plugins/rating/rating.css" type="text/css" />
<link rel="stylesheet" href="//themes/default/styles/light.css" type="text/css" />

So there are a couple of lines where it uses the original URL (http://galtest.somedomain.org) for js etc, but mostly they start with just “/”. I’m not sure but I think this causes the problems. All those files exists.

Btw, there’s a newer ZenPhoto version available than the installer provides. :slight_smile:

Problem solved. I opened /zp-core/zp-config.php and commented out “define(‘WEBPATH’, ‘/’);”. Now it works. Thanks! :slight_smile: