yum update problem

Hi,

I tried yum update on CentOS 4.5 ( with virtualmin professional installed ) and I got the following error :

Error: Missing Dependency: clamav = 0.88.4-2.vm is needed by package clamd
Error: Missing Dependency: libclamav.so.1 is needed by package clamd

any solution for solving the problem ?

_Hamid

Howdy Hamid,

I dunno. I’m not sure why my php5 would have any problems with any of the php stuff–they’re supposed to co-exist peacefully. I’m looking into it.

I have the Same problem on my CentOS4.5:

[root@aero1 ~]# yum update
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
–> Populating transaction set with selected packages. Please wait.
—> Package php.i386 0:4.3.9-3.32.5.vm set to be updated
–> Running transaction check
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-snmp
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-domxml
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-pgsql
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-devel
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-ncurses
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-gd
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-odbc
–> Processing Dependency: php5 = 5.2.2-3vm for package: php5-devel
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-pear
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-xmlrpc
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-mysql
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-mbstring
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-ldap
–> Processing Dependency: php = 4.3.9-3.32vm for package: php-imap
–> Restarting Dependency Resolution with new changes.
–> Populating transaction set with selected packages. Please wait.
—> Package php-gd.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-imap.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-mbstring.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-xmlrpc.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-devel.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-snmp.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-domxml.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-ldap.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-ncurses.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-pear.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-pgsql.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-mysql.i386 0:4.3.9-3.32.5.vm set to be updated
—> Package php-odbc.i386 0:4.3.9-3.32.5.vm set to be updated
–> Running transaction check
–> Processing Dependency: php5 = 5.2.2-3vm for package: php5-devel
–> Finished Dependency Resolution
Error: Missing Dependency: php5 = 5.2.2-3vm is needed by package php5-devel

Joe,

Any updates on the issue ? I am still waiting for the new php update and the dependency problem still exist.

_Hamid

All I did was yum remove php5-devel, did my yum update and when complete did a yum install php5-devel again.

This seemed to overcome the problem.

Yeah, I’m working on it. In the meantime, you could probably remove the clamd package explicitly, and then install all of the clamav* packages.

rpm -e clamd

yum install clamav*

I don’t actually know that this will work…and if it doesn’t, don’t force it. I’ll have packages with corrected dependencies in the repo shortly.

Im having the same problem and I tried as Joe suggested above. Here is the error part of the output from that…

clamav-update-0.92-1.vm.e 100% |=========================| 18 kB 00:00 ---> Package clamav-update.x86_64 0:0.92-1.vm.el5 set to be updated --> Running transaction check --> Processing Conflict: clamav-data conflicts data(clamav) < full --> Processing Conflict: clamav-data-empty conflicts data(clamav) > empty --> Finished Dependency Resolution Error: clamav-data conflicts with data(clamav) < full Error: clamav-data-empty conflicts with data(clamav) > empty

CentOS 4.4/64

I didn’t work. it replies :

rpm -e clamd

error: Failed dependencies:
/usr/sbin/clamd is needed by (installed) virtualmin-base-1.0-48.rh.noarch

still waiting for corrected dependencies in the repo to update.
Also am I safe to upgrade to CentOS 4.6 from 4.5 with the virtualmin installed on it ?

Joe,

Will your updates address these issues as well?

http://www.virtualmin.com/forums/help-home-for-newbies/re%3Aclamav-wont-update.html#9450

rpm -e --nodeps --justdb --noscripts clamd

will remove the package from the rpm database but will not actually delete any files because of the noscripts switch.

any fix yet?

also anxious to see a solution for this; purchased a dedicated host using CentOS 4.4 and tried to install virtualmin, received a very similar error:

[code:1]
INFO - yum -y -d 2 install virtualmin-base
INFO - …in progress, please wait… |Error: Missing Dependency: clamav = 0.88.4-2.vm is needed by package clamd
Error: Missing Dependency: libclamav.so.1 is needed by package clamd …in progress, please wait… failed. Error (if any): 0
[/code:1]

For my particular install on CentOS 5.1 x86_64 I received a similar error.

when running this command:
yum --enablerepo=rpmforge install clamav clamav-db clamav-milter clamd -y

…in lieu of this rpm install:
rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm

…which is in lieu of this guide:
http://www.howtoforge.com/virtual-hosting-with-virtualmin-on-centos5.1-p2

I receive a similar error:
clamav-filesystem conflicts with clamav…

Of course, you can’t just:
yum remove clamav-filesystem
…as that would require you remove virtualmin-base.

To "solve" this problem:
rpm -e --nodeps clamav-filesystem

…and then rerun the above
Then re-run the above:
yum --enablerepo=rpmforge install clamav clamav-db clamav-milter clamd -y

Of course then you have the new problem of VM trying to update clamav to it’s version…I think this only happens in x86_64 settings.

I presume this is the same issue, but I am hoping to see a solution soon as well.

Loaded plugins: fastestmirror, priorities Loading mirror speeds from cached hostfile * rpmforge: ftp-stud.fht-esslingen.de * extras: chi-10g-1-mirror.fastsoft.net * updates: updates.interworx.info * base: chi-10g-1-mirror.fastsoft.net * addons: updates.interworx.info Setting up Update Process Resolving Dependencies --> Running transaction check ---> Package clamav.x86_64 0:0.95.1-4.el5.rf set to be updated --> Processing Dependency: clamav-db for package: clamav --> Running transaction check ---> Package clamav-db.x86_64 0:0.95.1-4.el5.rf set to be updated --> Processing Dependency: data(clamav) for package: clamav-lib --> Processing Dependency: data(clamav) for package: clamav-server --> Running transaction check ---> Package clamd.x86_64 0:0.95.1-4.el5.rf set to be updated --> Processing Dependency: clamav-server = 0.95.1-1.vm.el5 for package: clamav-server-sysv --> Processing Conflict: clamav-filesystem conflicts clamav > 0.95.1-1.vm.el5 --> Processing Conflict: clamav-filesystem conflicts clamav > 0.95.1-1.vm.el5 --> Finished Dependency Resolution clamav-filesystem-0.95.1-1.vm.el5.x86_64 from installed has depsolving problems --> clamav-filesystem conflicts with clamav clamav-server-sysv-0.95.1-1.vm.el5.x86_64 from installed has depsolving problems --> Missing Dependency: clamav-server = 0.95.1-1.vm.el5 is needed by package clamav-server-sysv-0.95.1-1.vm.el5.x86_64 (installed) Error: clamav-filesystem conflicts with clamav Error: Missing Dependency: clamav-server = 0.95.1-1.vm.el5 is needed by package clamav-server-sysv-0.95.1-1.vm.el5.x86_64 (installed)

Issues like that can crop up when multiple third-party repo’s are enabled, and begin to conflict with one another.

Here’s a thread where Joe talks about that a bit:

http://www.virtualmin.com/forums/virtualmin/clamav-will-not-update.html

It is the same issue, and the solution is always the same: Don’t try to use two incompatible versions of the same package. You have to choose one or the other. You have two yum repositories enabled that have clamav packages…and they are not compatible with one another (ours is based on the EPEL package). You can’t use them both.

Oh, actually it’s not the same issue at all. The original issue was my fault. The new issue being discussed is your fault. :wink: