yum update not working due to dependencies, which are not installed??

I run yum update and get the below errors. I thought yum is supposed to deal with dependencies.

I need to update it because I want to install DKIM for email but that fails with similar errors.

Thanks


Transaction Summary

Install 38 Package(s)
Upgrade 38 Package(s)

Total size: 153 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libcrypto.so.10 is needed by mysql-libs-5.1.73-3.el6_5.i686
libcrypto.so.10(libcrypto.so.10) is needed by mysql-libs-5.1.73-3.el6_5.i686
libssl.so.10 is needed by mysql-libs-5.1.73-3.el6_5.i686
libssl.so.10(libssl.so.10) is needed by mysql-libs-5.1.73-3.el6_5.i686
libnspr4.so is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.10) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.11) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.11.1) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.12) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.12.1) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.12.5) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.12.9) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.2) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.3) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.4) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.6) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.8) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.9.2) is needed by openldap-2.4.23-34.el6_5.1.i686
libnss3.so(NSS_3.9.3) is needed by openldap-2.4.23-34.el6_5.1.i686
libnssutil3.so is needed by openldap-2.4.23-34.el6_5.1.i686
libplc4.so is needed by openldap-2.4.23-34.el6_5.1.i686
libplds4.so is needed by openldap-2.4.23-34.el6_5.1.i686
libsmime3.so is needed by openldap-2.4.23-34.el6_5.1.i686
libssl3.so is needed by openldap-2.4.23-34.el6_5.1.i686
libssl3.so(NSS_3.2) is needed by openldap-2.4.23-34.el6_5.1.i686
libssl3.so(NSS_3.4) is needed by openldap-2.4.23-34.el6_5.1.i686
libssl3.so(NSS_3.7.4) is needed by openldap-2.4.23-34.el6_5.1.i686
libcrypto.so.10 is needed by openssl-devel-1.0.1e-16.el6_5.4.i686
libssl.so.10 is needed by openssl-devel-1.0.1e-16.el6_5.4.i686
libmysqlclient.so.16()(64bit) is needed by mysql-5.1.73-3.el6_5.x86_64
libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by mysql-5.1.73-3.el6_5.x86_64
libmysqlclient_r.so.16()(64bit) is needed by mysql-5.1.73-3.el6_5.x86_64
libmysqlclient_r.so.16(libmysqlclient_16)(64bit) is needed by mysql-5.1.73-3.el6_5.x86_64
libmysqlclient.so.16()(64bit) is needed by mysql-server-5.1.73-3.el6_5.x86_64
libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by mysql-server-5.1.73-3.el6_5.x86_64
libmysqlclient_r.so.16()(64bit) is needed by mysql-server-5.1.73-3.el6_5.x86_64
libmysqlclient_r.so.16(libmysqlclient_16)(64bit) is needed by mysql-server-5.1.73-3.el6_5.x86_64
libnss3.so is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so is needed by (installed) elinks-0.12-0.21.pre5.el6_3.i686
libnss3.so is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so is needed by (installed) curl-7.19.7-37.el6_4.i686
libnss3.so is needed by (installed) rpm-libs-4.8.0-37.el6.i686
libnss3.so is needed by (installed) rpm-4.8.0-37.el6.i686
libnss3.so is needed by (installed) mailx-12.4-7.el6.i686
libnss3.so is needed by (installed) openssh-5.3p1-94.el6.i686
libnss3.so is needed by (installed) rpm-python-4.8.0-37.el6.i686
libnss3.so is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libnss3.so is needed by (installed) openssh-server-5.3p1-94.el6.i686
libnss3.so is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.10) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.10) is needed by (installed) rpm-libs-4.8.0-37.el6.i686
libnss3.so(NSS_3.11) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.11.2) is needed by (installed) rpm-libs-4.8.0-37.el6.i686
libnss3.so(NSS_3.12) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.12) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.12) is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libnss3.so(NSS_3.12.1) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.12.5) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.2) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.2) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.2) is needed by (installed) rpm-libs-4.8.0-37.el6.i686
libnss3.so(NSS_3.2) is needed by (installed) mailx-12.4-7.el6.i686
libnss3.so(NSS_3.2) is needed by (installed) openssh-5.3p1-94.el6.i686
libnss3.so(NSS_3.2) is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libnss3.so(NSS_3.2) is needed by (installed) openssh-server-5.3p1-94.el6.i686
libnss3.so(NSS_3.2) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.3) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.3) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.3) is needed by (installed) openssh-5.3p1-94.el6.i686
libnss3.so(NSS_3.3) is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libnss3.so(NSS_3.3) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.4) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.4) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.4) is needed by (installed) rpm-libs-4.8.0-37.el6.i686
libnss3.so(NSS_3.4) is needed by (installed) mailx-12.4-7.el6.i686
libnss3.so(NSS_3.4) is needed by (installed) openssh-5.3p1-94.el6.i686
libnss3.so(NSS_3.4) is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libnss3.so(NSS_3.4) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.5) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.5) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.5) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.6) is needed by (installed) openssh-5.3p1-94.el6.i686
libnss3.so(NSS_3.6) is needed by (installed) openssh-server-5.3p1-94.el6.i686
libnss3.so(NSS_3.6) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.7) is needed by (installed) mailx-12.4-7.el6.i686
libnss3.so(NSS_3.9) is needed by (installed) openssh-5.3p1-94.el6.i686
libnss3.so(NSS_3.9) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.9.2) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.9.2) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.9.2) is needed by (installed) openssh-5.3p1-94.el6.i686
libnss3.so(NSS_3.9.2) is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libnss3.so(NSS_3.9.2) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libnss3.so(NSS_3.9.3) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnss3.so(NSS_3.9.3) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnss3.so(NSS_3.9.3) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libsmime3.so is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libsmime3.so is needed by (installed) elinks-0.12-0.21.pre5.el6_3.i686
libsmime3.so is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libsmime3.so is needed by (installed) curl-7.19.7-37.el6_4.i686
libsmime3.so is needed by (installed) mailx-12.4-7.el6.i686
libsmime3.so is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libsmime3.so(NSS_3.2) is needed by (installed) mailx-12.4-7.el6.i686
libsmime3.so(NSS_3.6) is needed by (installed) mailx-12.4-7.el6.i686
libssl3.so is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libssl3.so is needed by (installed) elinks-0.12-0.21.pre5.el6_3.i686
libssl3.so is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libssl3.so is needed by (installed) curl-7.19.7-37.el6_4.i686
libssl3.so is needed by (installed) mailx-12.4-7.el6.i686
libssl3.so is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libssl3.so(NSS_3.11.4) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libssl3.so(NSS_3.2) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libssl3.so(NSS_3.2) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libssl3.so(NSS_3.2) is needed by (installed) mailx-12.4-7.el6.i686
libssl3.so(NSS_3.2) is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libssl3.so(NSS_3.4) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libssl3.so(NSS_3.4) is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libssl3.so(NSS_3.7.4) is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libcrypto.so.10 is needed by (installed) postfix-2:2.6.6-2.2.el6_1.i686
libcrypto.so.10 is needed by (installed) fipscheck-1.2.0-7.el6.i686
libcrypto.so.10 is needed by (installed) perl-Net-SSLeay-1.35-9.el6.i686
libcrypto.so.10 is needed by (installed) perl-DBD-MySQL-4.013-3.el6.i686
libcrypto.so.10 is needed by (installed) perl-Crypt-OpenSSL-Random-0.04-9.1.el6.i686
libcrypto.so.10 is needed by (installed) perl-Crypt-OpenSSL-Bignum-0.04-8.1.el6.i686
libcrypto.so.10 is needed by (installed) perl-Crypt-OpenSSL-RSA-0.25-10.1.el6.i686
libcrypto.so.10 is needed by (installed) libc-client-2007e-11.el6.i686
libcrypto.so.10 is needed by (installed) perl-Crypt-SSLeay-0.57-16.el6.i686
libcrypto.so.10 is needed by (installed) tcpdump-14:4.0.0-3.20090921gitdf3cb4.2.el6.i686
libcrypto.so.10 is needed by (installed) libssh2-1.4.2-1.el6.i686
libcrypto.so.10 is needed by (installed) cyrus-sasl-2.1.23-13.el6_3.1.i686
libcrypto.so.10 is needed by (installed) cyrus-sasl-md5-2.1.23-13.el6_3.1.i686
libcrypto.so.10 is needed by (installed) httpd-tools-1:2.2.15-29.el6.vm.1.i686
libcrypto.so.10 is needed by (installed) mod_ssl-2:2.2.15-29.el6.vm.1.i686
libcrypto.so.10 is needed by (installed) postgresql-libs-8.4.18-1.el6_4.i686
libcrypto.so.10 is needed by (installed) ruby-libs-1.8.7.352-13.el6.i686
libcrypto.so.10 is needed by (installed) net-snmp-libs-1:5.5-49.el6.i686
libcrypto.so.10 is needed by (installed) openssh-5.3p1-94.el6.i686
libcrypto.so.10 is needed by (installed) net-snmp-1:5.5-49.el6.i686
libcrypto.so.10 is needed by (installed) php-cli-5.3.3-27.el6_5.i686
libcrypto.so.10 is needed by (installed) ntpdate-4.2.6p5-1.el6.centos.i686
libcrypto.so.10 is needed by (installed) ntp-4.2.6p5-1.el6.centos.i686
libcrypto.so.10 is needed by (installed) php-5.3.3-27.el6_5.i686
libcrypto.so.10 is needed by (installed) postgresql-server-8.4.18-1.el6_4.i686
libcrypto.so.10 is needed by (installed) openssh-server-5.3p1-94.el6.i686
libcrypto.so.10 is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libcrypto.so.10 is needed by (installed) php-mysql-5.3.3-27.el6_5.i686
libcrypto.so.10 is needed by (installed) spamassassin-3.3.1-3.el6.i686
libcrypto.so.10 is needed by (installed) php-imap-5.3.3-27.el6_5.i686
libcrypto.so.10 is needed by (installed) dovecot-1:2.0.9-7.el6.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) net-snmp-libs-1:5.5-49.el6.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) openssh-5.3p1-94.el6.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) php-cli-5.3.3-27.el6_5.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) ntpdate-4.2.6p5-1.el6.centos.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) ntp-4.2.6p5-1.el6.centos.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) php-5.3.3-27.el6_5.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) openssh-server-5.3p1-94.el6.i686
libcrypto.so.10(OPENSSL_1.0.1) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) ruby-libs-1.8.7.352-13.el6.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) net-snmp-libs-1:5.5-49.el6.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) openssh-5.3p1-94.el6.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) php-cli-5.3.3-27.el6_5.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) ntpdate-4.2.6p5-1.el6.centos.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) ntp-4.2.6p5-1.el6.centos.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) php-5.3.3-27.el6_5.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) openssh-server-5.3p1-94.el6.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libcrypto.so.10(libcrypto.so.10) is needed by (installed) dovecot-1:2.0.9-7.el6.i686
libssl.so.10 is needed by (installed) postfix-2:2.6.6-2.2.el6_1.i686
libssl.so.10 is needed by (installed) perl-Net-SSLeay-1.35-9.el6.i686
libssl.so.10 is needed by (installed) perl-DBD-MySQL-4.013-3.el6.i686
libssl.so.10 is needed by (installed) perl-Crypt-OpenSSL-Random-0.04-9.1.el6.i686
libssl.so.10 is needed by (installed) perl-Crypt-OpenSSL-RSA-0.25-10.1.el6.i686
libssl.so.10 is needed by (installed) libc-client-2007e-11.el6.i686
libssl.so.10 is needed by (installed) perl-Crypt-SSLeay-0.57-16.el6.i686
libssl.so.10 is needed by (installed) libssh2-1.4.2-1.el6.i686
libssl.so.10 is needed by (installed) httpd-tools-1:2.2.15-29.el6.vm.1.i686
libssl.so.10 is needed by (installed) mod_ssl-2:2.2.15-29.el6.vm.1.i686
libssl.so.10 is needed by (installed) postgresql-libs-8.4.18-1.el6_4.i686
libssl.so.10 is needed by (installed) ruby-libs-1.8.7.352-13.el6.i686
libssl.so.10 is needed by (installed) postgresql-8.4.18-1.el6_4.i686
libssl.so.10 is needed by (installed) php-cli-5.3.3-27.el6_5.i686
libssl.so.10 is needed by (installed) php-5.3.3-27.el6_5.i686
libssl.so.10 is needed by (installed) postgresql-server-8.4.18-1.el6_4.i686
libssl.so.10 is needed by (installed) php-mysql-5.3.3-27.el6_5.i686
libssl.so.10 is needed by (installed) spamassassin-3.3.1-3.el6.i686
libssl.so.10 is needed by (installed) php-imap-5.3.3-27.el6_5.i686
libssl.so.10 is needed by (installed) dovecot-1:2.0.9-7.el6.i686
libssl.so.10(libssl.so.10) is needed by (installed) ruby-libs-1.8.7.352-13.el6.i686
libssl.so.10(libssl.so.10) is needed by (installed) php-cli-5.3.3-27.el6_5.i686
libssl.so.10(libssl.so.10) is needed by (installed) php-5.3.3-27.el6_5.i686
libssl.so.10(libssl.so.10) is needed by (installed) spamassassin-3.3.1-3.el6.i686
libssl.so.10(libssl.so.10) is needed by (installed) dovecot-1:2.0.9-7.el6.i686
libnssutil3.so is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnssutil3.so is needed by (installed) elinks-0.12-0.21.pre5.el6_3.i686
libnssutil3.so is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnssutil3.so is needed by (installed) curl-7.19.7-37.el6_4.i686
libnssutil3.so is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libnssutil3.so is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libnssutil3.so(NSSUTIL_3.12) is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libnssutil3.so(NSSUTIL_3.12.3) is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libnssutil3.so(NSSUTIL_3.13) is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libnssutil3.so(NSSUTIL_3.14) is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libpython2.6.so.1.0 is needed by (installed) yum-metadata-parser-1.1.2-16.el6.i686
libpython2.6.so.1.0 is needed by (installed) pygpgme-0.1-18.20090824bzr68.el6.i686
libpython2.6.so.1.0 is needed by (installed) python-pycurl-7.19.0-8.el6.i686
libpython2.6.so.1.0 is needed by (installed) vim-enhanced-2:7.2.411-1.8.el6.i686
libpython2.6.so.1.0 is needed by (installed) mailman-3:2.1.12-18.el6.i686
libpython2.6.so.1.0 is needed by (installed) libxml2-python-2.7.6-14.el6.i686
libpython2.6.so.1.0 is needed by (installed) rpm-python-4.8.0-37.el6.i686
libpython2.6.so.1.0 is needed by (installed) python-ethtool-0.6-5.el6.i686
libnspr4.so is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libnspr4.so is needed by (installed) elinks-0.12-0.21.pre5.el6_3.i686
libnspr4.so is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libnspr4.so is needed by (installed) curl-7.19.7-37.el6_4.i686
libnspr4.so is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libnspr4.so is needed by (installed) mailx-12.4-7.el6.i686
libnspr4.so is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libplc4.so is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libplc4.so is needed by (installed) elinks-0.12-0.21.pre5.el6_3.i686
libplc4.so is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libplc4.so is needed by (installed) curl-7.19.7-37.el6_4.i686
libplc4.so is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libplc4.so is needed by (installed) mailx-12.4-7.el6.i686
libplc4.so is needed by (installed) openssh-5.3p1-94.el6.i686
libplc4.so is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
libplc4.so is needed by (installed) openssh-clients-5.3p1-94.el6.i686
libplds4.so is needed by (installed) nss_compat_ossl-0.9.6-1.el6.i686
libplds4.so is needed by (installed) elinks-0.12-0.21.pre5.el6_3.i686
libplds4.so is needed by (installed) libcurl-7.19.7-37.el6_4.i686
libplds4.so is needed by (installed) curl-7.19.7-37.el6_4.i686
libplds4.so is needed by (installed) nss-softokn-3.14.3-9.el6.i686
libplds4.so is needed by (installed) abrt-addon-ccpp-2.0.8-21.el6.centos.i686
You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2014-02-18-11-28razYrZ.yumtx

some other posts online state could be a repo clash… so yum repolist shows this:

repo id repo name status

base CentOS-6 - Base 6,367

cloudmin-universal Cloudmin Distribution Neutral 141

epel Extra Packages for Enterprise Linux 6 - x86_64 10,487

extras CentOS-6 - Extras 14

newrelic New Relic packages for Enterprise Linux 5 - x86_64 5

updates CentOS-6 - Updates 518

varnish-3.0 Varnish 3.0 for Enterprise Linux 5 - x86_64 54

virtualmin RHEL/CentOS/Scientific 6 - x86_64 - Virtualmin 102

virtualmin-universal Virtualmin Distribution Neutral Packages 185

This command does not output anything:

rpm -Va --nofiles --nodigest

Here is the strange thing… this server is a clone of another from Linode. Basically I created a new VPS with Linode, and cloned a backup from another server to this one.

The original server all updated fine. This new server shows the errors. Yet they should be identical apart from IP/hostname.

Howdy,

What is the output of this command:

uname -a

Also, can you show the packages that it’s trying to update? Seeing what repository those are coming from may help us figure out what the problem is.

However, you could always try disabling the EPEL, newrelic, and Varnish repositories, as those are all third party repositories and could cause the problem you’re seeing.

-Eric

uname -s is:
Linux myhostname.co.uk 3.12.9-x86_64-linodexx #1 SMP Mon Feb 3 10:01:02 EST 2014 x86_64 x86_64 x86_64 GNU/Linux

(myhostname.co.uk is of course changed, I dont see a reason to advertise it? and linodexx)

I disabled those repos, but still get the same issue:

Here’s what yum updates shows:

Package Arch Version Repository Size

=========================================================================================================================================================================

Updating:

bind x86_64 32:9.8.2-0.23.rc1.el6_5.1 updates 4.0 M

bind-libs i686 32:9.8.2-0.23.rc1.el6_5.1 updates 891 k

bind-utils x86_64 32:9.8.2-0.23.rc1.el6_5.1 updates 182 k

ca-certificates noarch 2013.1.95-65.1.el6_5 updates 1.1 M

ethtool x86_64 2:3.5-1.2.el6_5 updates 100 k

irqbalance x86_64 2:1.0.4-8.el6_5 updates 37 k

kernel-firmware noarch 2.6.32-431.5.1.el6 updates 13 M

kernel-headers x86_64 2.6.32-431.5.1.el6 updates 2.8 M

mysql x86_64 5.1.73-3.el6_5 updates 894 k

mysql-devel i686 5.1.73-3.el6_5 updates 129 k

mysql-libs i686 5.1.73-3.el6_5 updates 1.2 M

mysql-server x86_64 5.1.73-3.el6_5 updates 8.6 M

nspr i686 4.10.2-1.el6_5 updates 115 k

nss i686 3.15.3-6.el6_5 updates 826 k

nss-sysinit x86_64 3.15.3-6.el6_5 updates 40 k

nss-tools x86_64 3.15.3-6.el6_5 updates 358 k

nss-util i686 3.15.3-1.el6_5 updates 64 k

openldap i686 2.4.23-34.el6_5.1 updates 267 k

openssl i686 1.0.1e-16.el6_5.4 updates 1.5 M

openssl-devel i686 1.0.1e-16.el6_5.4 updates 1.2 M

p11-kit i686 0.18.5-2.el6_5.2 updates 93 k

p11-kit-trust i686 0.18.5-2.el6_5.2 updates 68 k

pixman i686 0.26.2-5.1.el6_5 updates 206 k

python x86_64 2.6.6-52.el6 updates 74 k

python-libs i686 2.6.6-52.el6 updates 5.3 M

tzdata noarch 2013i-2.el6 updates 448 k

wget x86_64 1.12-1.11.el6_5 updates 483 k

yum noarch 3.2.29-43.el6.centos updates 996 k

yum-plugin-fastestmirror noarch 1.1.30-17.el6_5 updates 28 k

yum-plugin-security noarch 1.1.30-17.el6_5 updates 38 k

yum-utils noarch 1.1.30-17.el6_5 updates 102 k

Installing for dependencies:

bind-libs x86_64 32:9.8.2-0.23.rc1.el6_5.1 updates 879 k

bzip2-libs x86_64 1.0.5-7.el6_0 base 36 k

db4 x86_64 4.7.25-18.el6_4 base 563 k

expat x86_64 2.0.1-11.el6_2 base 76 k

gdbm x86_64 1.8.0-36.el6 base 29 k

glibc x86_64 2.12-1.132.el6 base 3.8 M

keyutils-libs x86_64 1.4-4.el6 base 20 k

krb5-libs x86_64 1.10.3-10.el6_4.6 base 761 k

libattr x86_64 2.4.44-7.el6 base 15 k

libcap x86_64 2.16-5.5.el6 base 32 k

libcap-ng x86_64 0.6.4-3.el6_0.1 base 21 k

libcom_err x86_64 1.41.12-18.el6 base 37 k

libffi x86_64 3.0.5-3.2.el6 base 26 k

libgcc x86_64 4.4.7-4.el6 base 101 k

libidn x86_64 1.18-2.el6 base 205 k

libselinux x86_64 2.0.94-5.3.el6_4.1 base 108 k

libstdc++ x86_64 4.4.7-4.el6 base 293 k

libxml2 x86_64 2.7.6-14.el6 base 799 k

mysql-libs x86_64 5.1.73-3.el6_5 updates 1.2 M

ncurses-libs x86_64 5.7-3.20090208.el6 base 246 k

nspr x86_64 4.10.2-1.el6_5 updates 113 k

nss x86_64 3.15.3-6.el6_5 updates 822 k

nss-softokn x86_64 3.14.3-9.el6 base 265 k

nss-softokn-freebl x86_64 3.14.3-9.el6 base 157 k

nss-util x86_64 3.15.3-1.el6_5 updates 64 k

numactl x86_64 2.0.7-8.el6 base 69 k

openssl x86_64 1.0.1e-16.el6_5.4 updates 1.5 M

python-libs x86_64 2.6.6-52.el6 updates 5.3 M

readline x86_64 6.0-4.el6 base 178 k

sqlite x86_64 3.6.20-1.el6 base 301 k

zlib x86_64 1.2.3-29.el6 base 73 k

Does anyone have an idea about this, or should I get a new server and re-install from scratch again?

i want to install Cloudmin on this server, and then enable DKIM, but I cant do either because yum fails.

As stated its really strange as this is a restore of a backup of another server, so should be identical, but the other server yum update worked OK!

OK I think I may have spotted the issue…

The original server that worked is i686, but this new one is x86_64. So somewhere along the line I must have chosen a 64bit computer (have no recollection of having that choice!) and then restored a 32bit backup onto it.

Yeah the issue that’s happening is that there’s a mix of 32 bit and 64 bit packages.

We’ve sometimes seen issues like that occur when a repository incorrectly includes a 32 bit dependency in a 64 bit package.

In that case, the fix is to remove the 32 bit packages, replacing them with 64 bit versions when necessary – and ultimately removing the culprit with the incorrect dependency.

However, if you think the issue is related to restoring an incorrect backup onto this server, that could do it too.

It may be not trivial to fix, since it seems to be affecting a lot of them, though it’s likely possible – you could try reviewing the various packages on your system, and see if you’re able to replace them with 64 bit versions.

-Eric

I have spoken to Linode who say 64bit is a default setup for new servers now… so I restored a 32bit snapshot of a virtualmin server onto this 64bit machine. I did not realise this could happen, so overlooked it. So I am confident this is the issue as opposed to issues with packages and repos.

I have decided I will create a new server again, 64bit, install Virtualmin from scratch and then move the accounts over as I dont have many accounts as its a new server. I am familiar with this process and not trying to fix this issue!

So I would say this issue is solved now.

Thanks