yum update errors


Currently getting the following error when running yum -y update:

[[jkmiller@s3 ~]]$ yum -y update
Gathering header information file(s) from server(s)
Server: Centos-3 - i386/i686 - Addons
Server: Centos-3 - i386/i686 - Base
Server: Centos-3 - i386/i686 - Extras
Server: Centos-3 - i386/i686 - Updates
Server: Red Hat Enterprise 3 - i386 - Virtualmin
Server: Virtualmin Distribution Neutral
Finding updated packages
Downloading needed headers
Resolving dependencies
Dependencies resolved
I will do the following:
[[update: openldap 2.0.27-20.i386]]
[[update: wbt-virtualmin-nuvola-dusk 1.230-1.noarch]]
[[update: wbt-virtualmin-nuvola-green 1.230-1.noarch]]
[[update: wbt-virtualmin-nuvola-pushup 1.230-1.noarch]]
[[update: wbt-virtualmin-nuvola 1.230-1.noarch]]
[[update: openldap-devel 2.0.27-20.i386]]
[[update: nss_ldap 207-17.i386]]
[[update: wbt-virtualmin-nuvola-raspberry 1.230-1.noarch]]
[[update: wbt-virtualmin-nuvola-chocmint 1.230-1.noarch]]
Downloading Packages
Getting openldap-2.0.27-20.i386.rpm
openldap-2.0.27-20.i386.r 100% |=========================| 393 kB 00:00
Getting wbt-virtualmin-nuvola-dusk-1.230-1.noarch.rpm
wbt-virtualmin-nuvola-dus 100% |=========================| 1.9 MB 00:00
Getting wbt-virtualmin-nuvola-green-1.230-1.noarch.rpm
wbt-virtualmin-nuvola-gre 100% |=========================| 1.9 MB 00:00
error: rpmts_HdrFromFdno: V3 DSA signature: BAD, key ID a0bdbcf9
Error Reading Header on /var/cache/yum/virtualmin-universal/packages/wbt-virtualmin-nuvola-green-1.230-1.noarch.rpm
Error: You may want to run yum clean or remove the file:

That’s the same error I got on a fresh install and posted to General Questions forum. I did not see yours until after I finished posting mine.

Should be fixed now. Thanks for the heads up.

I’ve clearly got a race condition in my update scripts somewhere…Seems like everytime I roll out an update either a couple of RPMs get corrupted or the header/repo generation step happens too soon and one or more headers get corrupted. I’m working on it.

Still not working, even after a yum clean.


Are we going to see a fix for this soon?

Argh. I thought it was fixed. I’m looking into it. Will be fixed shortly…I’ll ping this thread when I’ve confirmed it is all working.

Fixed, and tested working. It did bring to my attention a bug (I guess?) in yum (possibly just some versions). The "yum clean all" command does not in fact clean all headers and packages…in my case on RHEL3, it left behind the headers, and the error kept coming even after the problem with the package was fixed.

I had to do the following:

yum clean packages
yum clean headers

And for good measure I checked the /var/cache/yum/virtualmin-universal packages and headers directory manually, just to be sure…Darned thing had me pulling out my hair trying to figure out how the package could definitively have correct signature on the server and on the build system here, but not on the machine I was installing on.

Sorry for the inconvenience. This recurring problem with package corruption will get fixed ASAP…Or I’ll destroy all of my computers with a big hammer and go live in a cave.