Yum update breaks Proftp on FC4 virutalmin pro

I looked all through this forum and everywhere esle for several hours. No luck. I tried some things that might not be the right thing to do but in the end I got something to work.

When yum updates it must change the Virtuamin configuration for PAM. There is a proftp config file in /etc/pam.d (called 'proftp)with some pam config options I added another file called ‘ftp’ (just ftp ) with these options without removing the other file -proftp.

#%PAM-1.0
auth required pam_unix.so nullok
account required pam_unix.so
session required pam_unix.so

It worked.

Hey John,

This was a known bug several months ago…but I’m pretty sure it’s been fixed in our proftpd package. Are you sure you have our proftpd package and not one from some other repository?

You can check with:

rpm -q proftpd

If it has a “.vm” in the version, it is ours, and I’ll need to know what architecture you’re running on (i386 or x86_64), so I can correct our package.