Your system only has PHP version 7.2.17 installed, so selecting a different version for each directory is not possible.

Hi as you can see from

root@host-thirty:~# php -v
PHP (cli) (built: May 3 2019 09:57:22) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies
with Zend OPcache, Copyright © 1999-2017, by Zend Technologies

I have php 7.0 enabled on my Ubuntu 18.04 server. Php7.2 is disabled. But Virtualmin dont see this somehow and still tell me that I only have 7.2. We have apps in our webshop that dont work with 7.2

How can this be fixed??


You may want to try going into System Settings -> Re-Check Config, that will get Virtualmin to re-evaluate what PHP versions are on your server.


After performing this step, I am still getting the same message. Is there another way to force the PHP version for an existing (sub) server?


I just got tired of it and installed a earlier version of Ubuntu, (16.04) to get the correct php version for my needs