.. your system is not ready for use by Virtualmin.

I have a VPS with CentOS 64-bit and had virtualmin installed today.
I have 2GB RAM

I am use to cPanel and trying to learn as I go along.

I have ran the “Checking Configuration” and as it goes through it stops. I have disabled and prevented start on boot for mailman, spamassassin and clamav.

Your system has 1.83 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.

BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Your Postfix version does not support per-domain outgoing IP addresses.

Apache is installed.

The following PHP versions are available : 5.4.24 (/usr/bin/php-cgi)

Webalizer is installed.

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

The ClamAV program clamscan does not appear to be working properly :

ERROR: Can’t write to temporary directory

----------- SCAN SUMMARY -----------
Known viruses: 3090215
Engine version: 0.98.1
Scanned directories: 0
Scanned files: 0
Infected files: 0
Data scanned: 0.00 MB
Data read: 0.00 MB (ratio 0.00:1)
Time: 6.946 sec (0 m 6 s)

. Either change the program on the spam and virus scanners page, or disable this feature.

… your system is not ready for use by Virtualmin.

The thing is, I already have them disabled and they show they are disabled on boot.

I did the following just to be sure:

Stop webmin with: /etc/init.d/webmin stop

Look for a running Webmin process: ps auxw | grep miniserv | grep webmin

Use the "kill" command to kill any processes you find

Start up Webmin with: /etc/init.d/webmin start

What is wrong with the setup?

I have disabled all that is giving an error.


Hmm, it appears that you may have some packages installed from third party repositories. If ClamAV came from a third party repo, it may not be working properly, which would explain the issues you’re seeing.

What output does this command produce:

rpm -qa | grep clam

It was a fresh install today with some updates ran

the command gives me the following:

  • clamav-0.98.1-15.el6.art.x86_64
  • clamav-db-0.97.6-1.el6.x86_64
  • clamd-0.97.6-1.el6.x86_64
  • clamav-0.97.6-1.el6.x86_64

changing this comment, n/a

In addition to what Eric said: The immediate error I see in the check is “Cannot write to temporary directory”. So you might want to make sure that the access rights for “/tmp” are set to something like “777”. The default for Ubuntu is:

drwxrwxrwt 8 root root 4096 Jan 28 11:05 /tmp

Meaning read/write/execute access for everyone, also the sticky bit is set.

“The most common use of the sticky bit today is on directories. When the sticky bit is set, only the item’s owner, the directory’s owner, or the superuser can rename or delete files. Without the sticky bit set, any user with write and execute permissions for the directory can rename or delete contained files, regardless of owner. Typically this is set on the /tmp directory to prevent ordinary users from deleting or moving other users’ files.” (From Wikipedia)

If you wish to disable the spam filtering feature, it won’t suffice to disable the SpamAssassin service. You also need to turn off the respective Virtualmin feature under “Virtualmin -> System Settings -> Features and Plugins”. Otherwise Virtualmin will assume that you still want to use that feature and keep testing for it.


It does indeed appear that some third party repositories were enabled on your server.

So although it may have been a fresh install recently, some packages were pulled in from some non-standard repositories, and those third party packages are likely the cause of the problems you’re having.

If possible, my suggestion would be to perform a fresh installation of CentOS, but to not enable any third party repositories.

It appears that you have a version of PHP and ClamAV from the “ART” repository from the output I see above (there may be others installed as well).

Alternatively, you could try removing the version of ClamAV you have installed there, you could disable the ART repository, and then you could install the standard version of ClamAV from the Virtualmin software repository.


I check two tmp folders and they are both set to 777

/tmp and /var/tmp

How can I uninstall it from Cent OS 6.3 64bit?

I ran this command:
rpm -e --nodeps rpm -aq | grep -i clamav

and received this error:
warning: /etc/freshclam.conf saved as /etc/freshclam

Any help would be greatly appreciated!