Wrong site show up.

So i installed Centos 5.5 with no extras like apache etc. i then installed Virtualmin install.sh and everything looked ok.

however… i have the wrong site issue… except all domains point to /var/www/

i have googled and tried to solve this for 2 days now but failed.

thing is… in ‘apache webserver’ i have 3 sites a default one and the 2 sites i made… i did have another default but i deleted it hoping it would solve my problems.

i believe the default site i have in the list is to blame. here’s how it looks… the formatting is a bit off but i thnk you get the picture.

Type Address Port Server Name Document Root URL

Default Server Any Any Automatic /var/www/html Open…

now would someone please help me before i go insane and purchase plesk or something worse…

i have to say i relaly like virtualmin… nice and easy once you get the hang of it…

Best regards



Is there any chance you could post your httpd.conf file? That would aid in being able to get you all fixed up.

However, you’ll want to make sure that any NameVirtualhost and VirtualHost blocks in your httpd.conf file all have your IP address in them, and that none of them contain an asterisk (*).



Well, I see two things.

First, there may be an errant “NameVirtualhost” line in there. This particular line may be causing trouble:


There shouldn’t be a “.” at the end of that IP address.

Secondly, I only see one VirtualHost block in your httpd.conf file… the one that’s there points to “/home/fancyfeet.dk/public_html” and belongs to the domain “fancyfeet.dk”.

Which domain name is it you’re trying to browse to?


Hi Eric,

Thanks for looking into it.

i made a type when installing the OS…I already changed that last night after i posted the file.

I deleted all sites and made a new one… fancyfeet.dk

the thing is…fancyfeet.dk wont load the index file i placed in the /home/fancyfeet.dk/public_html
it loads content from /home/var/html/ as you can see if ou load fancyfeet.dk in your browser.

And if i add another domain it will load from the /var/www/html too.

Solved it with a reinstall… a little thing i learned from years of useing windows. :slight_smile:

thanks for looking into it.