Wrong Quota's and no Bandwith

Hello all,

I’m using Virtualmin 3.69 GPL on Ubuntu 8.04 for a while now, and I think it’s a very, very good program.
But since I had an update from Virtualmin or Webmin or something (I don’t know anymore for sure) there are some strange things.

I’ve got 4 virtual servers, and he shows how many of the Quota is in use, but at one server he constantly shows 442 MB, but when I log in to that server with FTP and download all the stuff that is in it, it only is 51 MB, so something is wrong there. It seems like the quotas stay on their level that it was when the most space was in use. When I delete a lot of stuff, the quotas in use doesn’t decrease.

Also something is wrong with the Bandwith. By a few of the servers (not all) he shows for more than a week 0 bytes now. But I know it should be a lot more.

I restarted the computer half an hour ago, to see if that would help, but the quotas are still wrong. I can’t say a lot about the bandwith because you can’t see that in half an hour.

Does somebody see what the problem is here?

Can you see from your logs if bw.pl is running, which updates all the bandwidth info?

Also, you can go into System Settings -> Bandwidth Monitoring and choose Recompute Statistics – does that change what shows up for the bandwidth?

For quotas – it may have gotten out of sync as well, try going into Limits and Validation -> Check Disk Quotas, and do another check using both Users and Groups.

In what kind of log do I have to look for bw.pl?
I looked at the Bandwith monitor just a minute ago, and in the week were it showed 0 bytes now some days show a bit or a lot bandwith, and the bandwith today is also still increasing. So I think that problem solved itself when I resbooted the computer.

I have tried the Check Disk Quotas option a lot of times but it doesn’t seem to solve the problem.

Since you’re using Ubuntu, you should just be able to grep for bw.pl in /var/log/syslog*. For example, on my Ubuntu server, I see:

syslog:Jun 13 12:00:02 core /USR/SBIN/CRON[7818]: (root) CMD (/etc/webmin/virtual-server/bw.pl)

Yeah, but my Bandwith Monitor is working again now, so my biggest problem are the quota’s now. But I looked it up for you, and yes, bw.pl is in that logs :wink:

When I look at “Edit Virtual Server”, and then Quota’s and Limits, then I see this:
“Home disk space used (including sub-servers) 442.14 MB (52.96 MB by server administrator, 0 bytes by mail / FTP users)”

So that 52,96 MB is what it should say, because that’s al the space the server is using. The 442 MB is what he has ever before used when a lot of big documents were on that server.
So now I don’t get why he keeps showing those 442,14 MB even if he isn’t using that much space anymore, he just did that a while ago.