Wordpress script and file permissions. No access to write files

Hi Joe,

I do not know where you got that info from? Did you interrogate the server? I have only done an automatic install following the virtualmin guides (and your videos) so if it has set mod_php it is not something I have done deliberately. I thought I had set FGGid.

However, things have moved on a lot since I first posted and in fact I closed the post but as I am still getting responses I will continue with it.

I have rebuilt the server twice from scratch now as I could not get it to work. First time was a vanilla of Debian 10 with webmin installed over the top. Could not get ssl certificates to work. So eventually started again and am having a bit more luck this time. I am using the OVH template to install a Debian 8 server running virtualmin. Again, problems with certificates but suddenly it installed the base names of xorex.rocks and www.xorex.rocks but it will not let me add mail. or webmail. or others. However, I have assumed (maybe incorrectly) that copying the certificate to the various modules (dovecot, postfix, ftp etc.) does the same thing.

Usermin did not work but that was a closed port and is now working properly. I am now trying to resolve postfix and dovecot as they installed in a bit of a mess. For some reason hostname was based on ovh.net and in dovecot, the certificates were based on a different virtual server to the one I have set as the main server. I have edited the config files and checked the config and it now looks right (but I may have introduced a new error unwittingly). I can now send mail successfully from usermin but the mail server is not receiving replies. Also, I cannot connect to the mail account using my AppleMail client which tells me the certificate is invalid.

Until I get each piece working I am not moving on. If you can help I would appreciate it. let me know what information you need and I will post it. I am trying hard to sort things on my own but I am far from expert and have to rely on people that have responded to help me get this working.

Many thanks.

Investigating the certificate issue I found that the certificate that is being seen is mail.ns1.xorex.rocks and not mail.xorex.rocks (or just xorex.rocks). I have renewed the xorex.rocks and www.xorex.rocks certificates and it told me it that it was copied to all the relevant modules. (I tried to add mail.xorex.rocks but got the same error message). Even after a reboot it still finds the wrong certificate. All the dovecot and postfix config appears correct so I do not understand why this is happening. I do not want to delete the virtual server but how can I disable its certificates to try to force the use of the correct one?


Now I am lost. I carefully copied and pasted the certificates from /home/xorex into the dovecot certificates dovecot.cert.pem and dovecot.key.pem but it still lists the certificate in use as ns1.xorex.rocks. How do I:

a) remove all certificates from the server
b) add back in the certificate for just xorex (I know how to do that)
c) rebuild dovecot so it uses the new certificate?


Just a bit more information.

When I run an ssl checker on xorex.rocks it shows the certificate for xorex.rocks
When I run an ssl checker on mail.xorex.rocks it shows the certificate for ns1.xorex.rocks not for xorex.rocks

Returned mails give an error of:

<xorex@xorex.rocks>: connect to mail.xorex.rocks[]:25: No route to host

I do not know if that helps or not.


lol, of course not. We have no way to do that.

I know because you said it started working when you changed ownership to www-data which would only work if Apache was running things instead of the domain owner user, which can only happen with mod_php in a default Virtualmin installation. Though maybe you’ve manually configured something.

Please start a new topic for new issues. Long threads like this are impossible for me to drop in on during the few minutes I have each day for the forums.

Will do. thanks Joe.

This post is closed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.