Wordpress: locked out of WP-Admin after LetsEncrypt

I have a Wordpress site that I wasnt using SSL with, then added SSL with Lets Encrypt, all done via the Virtualmin backend. I can now no longer access the Wp-Admin backend of my site, but I can access the rest of the pages. I get a 404 when I try to access wp-admin.

Any ideas? DId I miss a step?

In order to help we need to know more about your WordPress installation.

What security plugins do you use in WordPress?

How did you enable SSL in WordPress itself? (simplest method is often via an SSL plugin like Really Simple SSL)

Did you follow the WordPress codex/documentation on how to setup SSL?

Have you enabled debug in WordPress wp.config file to see what errors are being thrown

Have you checked apache logs?

For help on setting up SSL for Wordpress admin…https://wordpress.org/support/article/administration-over-ssl/

I also recommend these days to ensure that you install Wordfence Security. I moved away from this plugin in the past but now it has evolved I think into one of the best security plugins for WordPress https://wordpress.org/plugins/wordfence/

So I found out what the problem was. I had installed the WPS Hide Login plugin before I enabled SSL. The plugin was changing changing my wp-admin to http://url.com/login

So, I deleted the plugin via FTP then just re-installed it and it works.

you deleted the plugin via FTP???

why are you using FTP for file transfers and accessing public HTML directory? Virtualmin has a built-in file manager for this.

FTP is a security issue it is not recommended to be used at all anymore.

Isn’t that what ProFTPD comes with Virtualmin to solve?

ftp insecure? that sounds just like google excuses for removing ftp support from chrome.
people have the option of ftps, sftp and scp… much better (security-wise) than a production server file manager run in a browser…