Wordpress crashes server

Today try to install latest Wordpress script. By trying to login into the admin site, the whole crashes. The network connection goes down for about 5 min and then comes back itself.

OS: Debian Linux 6.0
Webmin Version 1.580
Virtualmin Version 3.91 Pro
WordPress Version to install 3.3.1

on a other website WordPress 3.3.1 runs fine, but same problem, when try to login, server crashes, we guess since the latest virtualmin update, wordpress crashes the whole server.
Any help greatly appreciated

Tobias

Howdy,

Well, a web app should never be able to bring your server down. If so, that may mean you’re running into some sort of available resource problem.

Are you by chance using a VPS? If so, what kind of VPS are you using?

Also, what is the output of this command:

free -m

Howdy, we are running a root server with:

free -m
total used free shared buffers cached
Mem: 7998 1726 6272 0 92 712
-/+ buffers/cache: 921 7076
Swap: 2053 0 2053

Howdy,

That all looks pretty normal… what about if you run the command “dmesg”, do you see any errors towards the end of that output?

-Eric

there is a problem with the NIC, we restarted the server,

[ 8.090153] Error: Driver ‘pcspkr’ is already registered, aborting…
[ 8.107894] [drm] nouveau 0000:02:00.0: Parsing VBIOS init table 2 at offset 0xE149
[ 8.107986] [drm] nouveau 0000:02:00.0: Parsing VBIOS init table 3 at offset 0xE23B
[ 8.115952] [drm] nouveau 0000:02:00.0: Parsing VBIOS init table 4 at offset 0xE447
[ 8.116097] [drm] nouveau 0000:02:00.0: Parsing VBIOS init table at offset 0xE4AC
[ 8.143795] [drm] nouveau 0000:02:00.0: 0xE4AC: Condition still not met after 20ms, skipping following opcodes
[ 8.143891] [drm] nouveau 0000:02:00.0: 0xC4B4: parsing output script 0
[ 8.245993] [TTM] Zone kernel: Available graphics memory: 4095252 kiB.
[ 8.246060] [TTM] Zone dma32: Available graphics memory: 2097152 kiB.
[ 8.246137] [drm] nouveau 0000:02:00.0: 256 MiB VRAM
[ 8.333767] [drm] nouveau 0000:02:00.0: 512 MiB GART (aperture)
[ 8.333832] mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
[ 8.334969] [drm] nouveau 0000:02:00.0: Allocating FIFO number 1
[ 8.353815] [drm] nouveau 0000:02:00.0: nouveau_channel_alloc: initialised FIFO 1
[ 8.356809] [drm] nouveau 0000:02:00.0: Detected a DAC output
[ 8.356876] [drm] nouveau 0000:02:00.0: Detected a TMDS output
[ 8.356942] [drm] nouveau 0000:02:00.0: Detected a DAC output
[ 8.357009] [drm] nouveau 0000:02:00.0: Detected a DVI-I connector
[ 8.357099] [drm] nouveau 0000:02:00.0: Detected a VGA connector
[ 8.474251] No connectors reported connected with modes
[ 8.474324] [drm] Initialized nouveau 0.0.15 20090420 for 0000:02:00.0 on minor 0
[ 8.762199] Adding 2102456k swap on /dev/md0. Priority:-1 extents:1 across:2102456k
[ 8.765350] EXT4-fs (md2): warning: maximal mount count reached, running e2fsck is recommended
[ 8.985983] loop: module loaded
[ 10.222227] kjournald starting. Commit interval 5 seconds
[ 10.222285] EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
[ 10.254293] EXT3 FS on md1, internal journal
[ 10.254415] EXT3-fs: mounted filesystem with ordered data mode.

[ 12.022481] r8169 0000:06:00.0: eth0: link down
[ 12.022569] r8169 0000:06:00.0: eth0: link down
[ 12.023281] ADDRCONF(NETDEV_UP): eth0: link is not ready

[ 13.228932] VFS (md2): Writes happened before quota was turned on thus quota information is probably inconsistent. Please run quotacheck(8).
[ 13.292134] VFS (md2): Writes happened before quota was turned on thus quota information is probably inconsistent. Please run quotacheck(8).
[ 13.706178] r8169 0000:06:00.0: eth0: link up
[ 13.706905] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 24.160535] eth0: no IPv6 routers present
[ 29.432616] ip_tables: © 2000-2006 Netfilter Core Team

I actually have the wrong NIC driver loaded: we have a r8168 chip but Debian loads the r8169 module,

06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

lsmod | grep r8168

lsmod | grep r8169
r8169 36872 0
mii 3210 1 r8169

ethtool -i eth0
driver: r8169
version: 2.3LK-NAPI
firmware-version: N/A
bus-info: 0000:06:00.0

we installed the r8168 driver, unfortunately the problem remains, have to change the NIC
best regards
Tobias

actually it was not the NIC it was a WordPress memory problem and my security settings, which dropped my IP into the hosts.deny file