Why Won't PHP Update?

I believe I followed all the instructions for bleeding edge… just trying to get wordpress to work.

ran :

rpm -ivh http://software.virtualmin.com/bleed/centos/5/x86_64/virtualmin-bleed-release-1.0-1.rhel.noarch.rpm

Then /etc/yum.repos.d/virtualmin-bleed-repo looks like this:

name=Red Hat Enterprise $releasever - $basearch - Virtualmin Bleeding
baseurl=http://software.virtualmin.com/bleed/centos/5/x86_64/ # tried em both

then I ran yum update php.

Nothing to install.

yum install php, I get

Package php-5.1.6-34.el5_8.i386 already installed and latest version
Nothing to do

I don’t think yum is looking at the repository, but I’m not sure. What am I doing wrong?


Also, why’s it say i386? This is an x86 machine.

per haps a “yum clean all” will help. It may need to rebuild the repos in its cache


What output do you get from these two commands:

uname -a file /bin/ls

Also, in the " /etc/yum.repos.d/virtualmin-bleed-repo" file you pasted above – the [virtualmin-bleed] block at the top is missing the opening [.

I suspect that may just be a cut and paste issue, but I figured I’d ask just in case :slight_smile:


Hi all

I am currently running
php.x86_64 5.2.17-1.el5.vmbleed

What about PHP 5.3 will that be possible to get in the repos?

  • Tim


CentOS 5 provides PHP 5.3 in the packages named “php53-". Currently, you have a number of PHP packages named "php-”.

If you want PHP 5.3, you can install that by removing your current PHP packages, and replacing them with the ones named “php53-*”.