Why is email so hard?

I have been trying to get email up and running for several days now and I’m still fighting it. I hate to compare this great product to cpanel, but with cpanel, email just works - why is it so hard here?

There are so many posts here in the forums that it is difficult to see the forest through the trees - needless to say, I’m a bit frustrated, I finally was able to get it to work but it shouldn’t be so difficult.

Some advice for those of you who find this post in the future. Use the command line to create users and forwarding, I find it much easier and it sets up the accounts properly. Specifically, postfix doesn’t like an “@” symbol in the user name, so when you use the command line, two users are created, joe@smith.com and joe-smith.com. Use the “-” account for logging in purposes.

When you create a forwarder and you have a user name of joe-smith.com, the “from” field should just be “joe” and not “joe-smith.com” Why? I have no idea but that is what it took for it too work.

I really do like Virtualmin/Webmin but the email functionality leaves a lot to be desired.

Howdy,

Sorry to hear that you had a hard time getting things working.

As you saw, there are some catches to using an ‘@’ in the username, since Postfix doesn’t natively support it.

That said, once you’ve enabled the user@domain format in System Settings -> Server Templates -> Default -> Mail for Domain, it shouldn’t matter how you create your users.

That is, whether you use the GUI or the command line, both should produce identical results. I use that particular format on a system I manage, and haven’t run into any issues creating users within the GUI.

So if you’re seeing problems, that may be a bug… and that sort of thing can be fixed :slight_smile:

Oh, and no one on your system need even know about using the users with a “-” in them. You should be able to log in using the user@domain users. If not, something’s not working right, and that also can be fixed :slight_smile:

-Eric

I just did a quick test run, I can receive email using the @ in the user name; however I was not able to send, when I changed to the -, it worked without a hitch.

I guess my point in these posts is that the default settings should be in place so that email just works, regardless of my OS, or version of Virtualmin. If I want to make some changes - i.e. clamd or spamassasin, etc then it’s on me to work through the details of getting it working, but when I install and hit go, I shouldn’t have to spend three days digging into the *.cf files and the forums to make it work.

Thank you

SASLAuthd needs to be told to use the “@” symbol for SMTP authentication.

You can do this by editing the /etc/sysconfig/saslauthd file. Make sure the “FLAGS” line reads:

FLAGS=-r

Then restart saslauthd:

service saslauthd restart

This should get your usernames working properly. Don’t feel bad, it took me several days to figure this out. I put a bug report in about this and really, really hope that Virtualmin makes this edit for you in the future whenever you enable the “user@domain” format.

I successfully enabled the username@sandbox.com username feature. However, prior to doing this I had several users with username.sandbox. So, now I have a mixed userbase. Some of the users appear with the old style login name, and some users have the new login name style.

  • username01.sandbox
  • username02.sandbox
  • username03.sandbox
  • username04.sandbox
  • username05@sandbox.com
  • username06@sandbox.com
  • username07@sandbox.com
  • username08@sandbox.com
Virtualmin does not give me the ability to change the usernames of the prior user accounts. Does anyone know how to change the old login names?

I don’t believe there’s a way to do that within the Virtualmin GUI… however, you may be able to do that using the command line tools.

If you run “virtualmin modify-user”, you’ll see a list of options. You may want to try out the “–newuser” param to change the username, that may allow you to reset the name (though I haven’t tested it, so this is an experiment :slight_smile:

-Eric

Thank you for the quick reply andreychek. I have linux command line phobias. LOL.

I actually did solve this problem through the virtualmin GUI. If you rename a users email address, and then rename it back, it automatically changes the email/FTP username to the new format.

old-email-address > new-email-address > old-email-address

Everything appears to be working normally after this change.

Okay, super, thanks for the update!

-Eric

where can I edit saslauthd in webmin?

Are you asking where to edit the file “/etc/sysconfig/saslauthd”?

I believe newer Webmin versions actually set that for you now when changing the mail format to user@domain.

However, if you’re looking for how to edit the “/etc/sysconfig/saslauthd” file from within Webmin, you can always browse out to it using the file manager.

So as root, go into Webmin -> Others -> File manager.

You can then browse out to that file, and choose “Edit” once you get to it.

-Eric

I was just curious if there was a module for it. I ended up editing in the CLI