WHMCS and Virtualmin error on create-domain

Hi there, I’m new to the forums but I’ve been using Virtualmin for a while.

I’ve spent HOURS over the last few weeks trying to get WHMCS to provision servers in Virtualmin GPL. I’ve read through all of the relevant documentation and forum posts a hundred times, and nothing makes it work.

I’ve got Module Logging enabled in WHMCS so I’ve got specific errors, I just don’t know what to change to get past them.

First off, I’ve had to put the root login and password in WHMCS against the server because setting up a new one with EXACTLY the same permissions fails to log in. This is something I want to fix once I can actually provision a server.

The error that I get when i accept an order (which should run the create-domain virtualmin function) comes back with:
Nginx cannot be enabled for a domain without a Unix user
Adds a new Virtualmin virtual server, with the settings and features
specified on the command line.
virtualmin create-domain --domain domain.name
–pass password-for-unix-user |
–passfile password-file
[–parent domain.name | --alias domain.name |
–alias-with-mail domain.name |
–superdom domain.name]
[–desc description-for-domain]
[–email contact-email]
[–user new-unix-user]
[–group new-unix-group]
[–default-features] | [–features-from-plan]
[–allocate-ip | --ip virtual.ip.address |
–shared-ip existing.ip.address]
[–dns-ip address | --no-dns-ip]
[–max-doms domains|]
[–max-aliasdoms domains]
[–max-realdoms domains]
[–max-mailboxes boxes]
[–max-dbs databases]
[–max-aliases aliases]
[–quota quota-for-domain|UNLIMITED]
[–uquota quota-for-unix-user|UNLIMITED]
[–bandwidth bytes]
[–template “name”]
[–plan “name”]
[–suffix username-prefix]
[–db database-name]
[–fwdto email-address]
[–reseller name]
[–mysql-pass password]
[–field-name value]

Exit status: 256

The API sent through this block (I’ve changed the domain, user and email for security):
[program] => create-domain
[domain] => domain.name
[user] => domainname
[pass] => 87brt8m6YY
[email] => email@address.com
[template] => Default Settings
[plan] => Shared 1GB
[features-from-plan] =>

The template and plan do exist and the names are EXACTLY the same between WHMCS and Virtualmin. I haven’t touched the Default Settings template since Virtualmin was installed.

As far as I can figure out, the create-domain API call isn’t creating a unix user (which it must do when you manually create a server in Virtualmin because I have about 40 unix users on the server, one for each server).

I’ve gone through every setting I can find in both WHMCS and Virtualmin looking for anything to do with creating a unix user and can’t find anything. All of the forum posts I see just say “set it up and it works, no difficult config required” but of course that doesn’t happen for me.

If anyone has any input, I would be very appreciative. I hope the above is enough to explain the issue.

Just bumping this, hoping that someone might be able to help

In case anyone comes across this in the future, there’s a setting in the Virtualmin PLAN called “Administration user” which must be enabled.

thank you, thank you very very much!