Where can I get help with this?

I don’t think paying for a pro support license would be able to help me with the below ?

Intro:
I have a very long ‘project website’ hosted on WP/Virtualmin, Total website ‘weight’ is just under 300gb.
I’m having significant issues with VirtualMin and loopback requests, causing WP to be unable to cron and do scan jobs, as in scans from a WAF. Other issues too.

In the past i have specified the alt.cron which has limited success, but was more functional.
Unknown if issue is on the ubuntu server, or the VirtualMin install, or configuration.

I have exhausted my capabilities in Linux, I dove head first into ubuntu server a couple of years ago and sorta dropped it, I was still interested in Linux but I was still a Windows guy.

Question:
Can paying for premium support help me with some of these issues?

I have no idea what this means.

What is the exact error?

It comes up in WP health. I have seen it before but not on my VM hosting.

Steve
P.S.

It’s not a Virtualmin issue. It’s a Wordpress configuration issue.

Well i just updated to WP 6 and did a vm checkpoint and moved the VM over to a different storage array (hack to fix vhd fragmentation.)
Currently site health shows the following, which is an improvement.
(and yes, server upgrade pending - it didn’t work last time)


Currently the issue seems to be fixed, but I will peruse that link Steve - thats a great resource from what i’ve read so far

Wow man.

If you had listed your OS from the beginning we all would have told you that 16.04 was end of life April 30th of 2021 and you need to upgrade it to at least 18.04.

Hard to tell you what’s going on when you don’t give us the information.

Yeah sorry about that - i often beaver away till the wee hours of the morning - to my peril.

That upgrade always fails, having another go now but got ubuntu serv issues with raising network interfaces

1 Like

You have to be careful not to update to 20.04 in one go. I know several people that were trying to do that and it caused a great deal of problems. From 16.04 you have to go to 18.04 first.

So watch that you’re not jumping two versions. That can cause a whole lot of problems.

This can be marked as resolved. The root cause for all the errors was discovered in the ubuntu server whereas interfaces.d specified ‘localhost’ to which there is no such interface.

@produKtnz

What was the issue solved with?

I’m sure you are perfectly fine that issue was not within Ubuntu, just asking for other users who might come across same issue you had and marked as resolved but no solution provided… do you care about virtualmin community?

Share with us how did you solved. I’m sure users will appreciate it. Don’t worry about me, I’m running on Debian and never had that issue. Thank you.

" I’m sure you are perfectly fine that issue was not within Ubuntu, " - err? thats the exact opposite of what i said :frowning:
I worked with a chap on a linux forum and we determined that the host (Ubuntu) was presenting ‘localhost’ to the programs running on top of Ubuntu (L.A.M.P) & Wordpress which was causing errors in functionality with loopback requests to wordpress - virtualmin was absolved of any responsibility shortly after, but making that determination was difficult because of the way the fault presented itself.
On occasion, CRON jobs would never end, if they managed to start in the first place. Spewcifying alt.cron to take over from CRON had some limited effect but that too was unreliable. Wordfence scans would not be started because the WAF couldn’t get back to itself owing to the looopback issue - media uploads were a sporadic issue too.

So VirtualMin was just the middle-man in thie fault scenario - it caused no faults of it’s own but the underlying server configuration sure did.