Where are the logs?

I just installed drupal in /home/honor/public_html. I have drupal installed on other virtual servers. I get this error code when I try to browse to it: The server encountered an internal error or misconfiguration and was unable to complete your request. How do I proceed to debug this? The site is ScoutFishing.com


The logs for a given website are in $HOME/logs/error_log.

You can also access them in Virtualmin using Logs and Reports -> Apache Error Log.

That error log should contain information about the error you’re seeing.


Option FollowSymLinks not allowed here

What’s a symlink?

Do I avoid or enable them and then how?

# Follow symbolic links in this directory. Options +FollowSymLinks


The FollowSymlinks is parameter disabled to to security issues. However, in it’s place, you could use the +SymLinksIfOwnerMatch parameter. That should prevent the error you’re seeing.


in .htaccess

# Follow symbolic links in this directory. Options +FollowSymLinks +SymLinksIfOwnerMatch

in /home/honor/public_html/.htaccess

# Follow symbolic links in this directory. Options +FollowSymLinks Options +SymLinksIfOwnerMatch

I restarted the httpd service and I even rebooted the server. I am also using -ctrl- when I hit refresh and -F5-.

Is there a way to re-enable SymLinks? I need it for Clean Urls in Drupal.

First I tried

chown -R honor public_html

Then I tried

chown -R apache public_html

I restarted apache inbetween the two codes and neither resolved the issue.

No idea on how to do this?

It looks like you’re trying to use both parameters.

You need to use “SymLinksIfOwnerMatch” instead of “FollowSymlinks”, rather than having both.

The FollowSymlinks parameter is generating an error, and using SymLinksIfOwnerMatch in it’s place will fix it.


I have installed Drupal 7.x on public_html. Instead of getting the install script I get:

No input file specified.

When I check the logs I see:

 [Mon Feb 25 05:57:43 2013] [error] [client] File does not exist: /home/honor/public_html/favicon.ico 

Here is the ls of /home/honor/public_html:

[root@epsilon public_html]# ls authorize.php icon INSTALL.sqlite.txt profiles themes awstats-icon includes INSTALL.txt README.txt update.php awstatsicons index.php LICENSE.txt robots.txt UPGRADE.txt CHANGELOG.txt INSTALL.mysql.txt MAINTAINERS.txt scripts web.config COPYRIGHT.txt INSTALL.pgsql.txt misc sites xmlrpc.php cron.php install.php modules stats


See if it helps to edit $HOME/etc/php.ini, and in there, look for “cgi.fix_pathinfo”.

When you find that, try setting that to “0” (and make sure it’s not commented out).


This is what I found:

 cgi.fix_pathinfo = On 

Here is more of it… I guess I need to change it from on to a zero

; cgi.fix_pathinfo provides *real* PATH_INFO/PATH_TRANSLATED support for CGI. PHP's ; previous behaviour was to set PATH_TRANSLATED to SCRIPT_FILENAME, and to not grok ; what PATH_INFO is. For more information on PATH_INFO, see the cgi specs. Setting ; this to 1 will cause PHP CGI to fix its paths to conform to the spec. A setting ; of zero causes PHP to behave as before. Default is 1. You should fix your scripts ; to use SCRIPT_FILENAME rather than PATH_TRANSLATED. ; http://www.php.net/manual/en/ini.core.php#ini.cgi.fix-pathinfo cgi.fix_pathinfo = On


It’s possible “Off” might work too, but yeah, I’d probably suggest just changing it to a ‘0’. Let us know if that does the trick!


OK. I changed it from

 cgi.fix_pathinfo = On 


cgi.fix_pathinfo = 0 

I am still getting this error displayed on ScoutFishing.com: No input file specified.

I am seeing this error in the Apache error log:

 [Wed Feb 27 12:01:49 2013] [error] [client] File does not exist: /home/honor/public_html/favicon.ico 

I then changed it to

cgi.fix_pathinfo = Off 

Still no fix. This shouldn’t be this hard that it takes me a week to get a website up. I appreciate the help, but this is incredibly frustrating for me. I just like for things to work and work effortlessly.

I have to ask… is there anyone I can pay to resolve this &%#$ issue for me? I was supposed to have this up and running last week, and now I look like a complete idiot. Please let me know.

Sorry for the trouble you’re having – normally this is effortless.

You should be able to perform a Drupal install with the Install Script, and it should work after that’s installed.

It looks like you’re using Virtualmin Pro there – with that in mind, we can take a deeper look for you, as our Premium Support service is something you’re paying for.

If you like, I can log in and look into what’s going awry there.

If that’s okay, you can either enable Remote Support using the Virtualmin Support module, or you can send me an email containing your root login details using eric@virtualmin.com.



Thanks for your email, I was able to login and look around.

It looks like the issue was that the public_html folder was owned by the user apache, rather than the Virtual Server owner.

Once I changed the folder to be owned by the Virtual Server owner, my test PHP script ran, and I can also see the Drupal installer.

Also, note that since you have Virtualmin Pro, you also have access to all the Install Scripts, which simplify the installation process of many web apps, including Drupal.

Rather than performing a manual installation, you could install Drupal by going into Install Scripts, and installing Drupal from there. That will handle configuring everything for you, including setting “SymlinksIfOwnerMatch” in place of the default “FollowSymlinks”.

Does all that seem to be working for you now?


Thanks Eric!!!