what uses lookup-domain.pl?

Just started this morning on my VirtualMin Pro hosting server, the lookup-domain.pl script is using 100% cpu. I keep killing the processes, but they keep coming back, even with Webmin not running. What is running that script? Is it needed?


So I renamed lookup-domain.pl and stopped webmin, and my server’s working now. When I start webmin up, it doesn’t respond. When I try the list-domains.pl script, it doesn’t respond. I think it has to do with a script I ran this morning, looking at the create-domain.pl script (working on integrating the VirtualMin API with some custom code). I ran:

[code:1]./create-domain.pl --domain donaldtesting.com --pass 123456pass --template "Shared Standard Hosting"[/code:1]

But now when I try to get it, the script can’t find the domain:

[code:1]./delete-domain.pl --domain donaldtesting.com
Virtual server donaldtesting.com does not exist

How can I manually delete the domain from VirtualMin’s database? Is that even possible? Help!

PS - The preview is unreadable due to white on gray text.

This issue is now being tracked in the bug at :

The solution to my problem was to remove the offending domain from the /etc/webmin/virtual-server/domains directory. Everything works now. Thanks Jamie!