What should write Postfix configuration ?

I recorded a new virtual server and now if I click on List Virtual Servers and then re-check and refresh configuration tells me

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

  A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration

… your system is not ready for use by Virtualmin.

have exactly the same problem with new installation of Virtualmin Pro on Debian 4.0

Then there is a solution to solve the problem I am?

The new version of Webmin broke the automated installation. I believe it is fixed with the latest version I rolled out an hour or so ago, but I might be wrong (testing is still in progress). See this news post about it:

http://www.virtualmin.com/forums/news/installer-issues-due-to-new-webmin-versions.html

I said that does not find virtualmin-base

What OS/version are you on, zonekjdx?

linux ubuntu server 7.10

That’s not a supported OS by our installer. No way it can possibly work…as there is no repository for Ubuntu 7.10.

Then I can not use

I have the same problem on Debian 4.0 Etch after a fresh Installation:

A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration

How can I fix it?

For the moment they are not yet able to solve the problem even I

Hello. I just fixed this problem.

Go to Webmin > Servers > Postfix > MailAliases

Where it says at the top:
[color=#0000FF]"Alias databases used by the local delivery agent"[/color]
Check the right hand radio button and type:
[color=#008000]hash:/etc/aliases[/color]
In the box.

That should fix it at least for Debian 4.0
You’ll most likely need to add a couple of apache modules too, in:
Webmin > Servers > apacheWebserver > GlobalConfiguration > configureApacheModules.

I had to add actions and suexec

I think there was one more error too, but can’t remember what it was.

I hope that helps you ou a bit.

I just fixed this problem.

Go to:

Webmin > Servers > PostfixMailServer >MailAliases

and type the following into the "Alias databases used by the local delivery agent" field.

hash:/etc/aliases

Check the radio button and save.

That got my postfix working on Debian 4.0

I have done so but not yet :frowning:

I have the same problem, I tried the steps above, and everything looks correct. I have a fresh install of Debian 4.0 RC3.

The error I get is: "A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration"

Any ideas?

I have the same problem

Hey guys,

See this thread in the News forum about this issue:

http://www.virtualmin.com/forums/news/installer-issues-due-to-new-webmin-versions.html

It’s a known problem with a simple solution. :wink:

I use ubuntu 7.10 servers do so:
Dpkg-r virtualmin-base
… The package is not installed
Apt.get install virtualmin-base
impossible to find Virtualmin-base
I do not know what to say but I virtualmin screen webmin can choose either virtualmin that webmin

Dpkg -r virtualmin-base

Apt-get install virtualmin-base

I correct typo:)
I want to help solve and start working with my server because I just sit in a function and do not understand how to operate if this does not work well virtualmin

I tried this as well with no luck, I get the same error.

[code:1]virtualmin1:~# Dpkg -r virtualmin-base
-bash: Dpkg: command not found
server:~# dpkg -r virtualmin-base
(Reading database … 63420 files and directories currently installed.)
Removing virtualmin-base …
server:~# Apt-get install virtualmin-base
-bash: Apt-get: command not found
virtualmin1:~# apt-get install virtualmin-base
Reading package lists… Done
Building dependency tree… Done
The following NEW packages will be installed:
virtualmin-base
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/9990B of archives.
After unpacking 34.8kB of additional disk space will be used.
Selecting previously deselected package virtualmin-base.
(Reading database … 63419 files and directories currently installed.)
Unpacking virtualmin-base (from …/virtualmin-base_1.0-14_all.deb) …
Setting up virtualmin-base (1.0-14) …

server:~#
[/code:1]

Any ideas?