Welcome Email not including password.

I’m having an issue, I’ve set virtualmin up and configured it to send out a welcome email with each virtual server created. The email sends fine, but the user’s password is never included. The account creation script errors out if I leave that field blank (thinking perhaps it would generate it’s own password).

Administration login: ${USER}

Administration password: ${PASS}

The Admin login field shows up fine, but the admin password line is always blank in the outgoing email.

Any thoughts?

Could this be due to not having virtualmin saving passwords in clear format? I choose the hashed option.

Okay I disabled the hashed password option, and allowed the server to randomly generate it’s own password instead of myself entering it manually, and the password field was properly included in the outgoing mail.

I couldn’t find the option to disable the password has inside the Virtualmin gui, so I manually disabled it in the file /etc/webmin/virtual-server/config


It sounds like you’ve got this one figured out, that’s great! I’ve asked Jamie for some more input on all that… I’m curious if that’s a bug that the ${PASS} variable isn’t working when using the hashed passwords.


Can you try using the option “${PLAINPASS}” when using the hashed passwords? It sounds like that may include what you’re after.


I tried the ${PLAINPASS} option, but that comes up blank as well. Then I changed the password storage to plaintext in the Server Template and tried it again. This time ${PASS} was sent successfully via email, but ${PLAINPASS} was still blank. It looks like a bug to me…


Okay, I can confirm that this is indeed a bug. I’ll ask Jamie to take a look :slight_smile:


Jamie found the source of that bug – it’ll be fixed in the next Virtualmin release, 3.90. Thanks for pointing it out!


I couldn’t find the bug in the bug database. Can you link to it here?

Edit: Nevermind, I found I wasn’t running 3.9. I am now. All is good.


i have now version 3.95 (before 3.94) and i still have the problem that ${PASS} and $[PLAINPASS} is empty.
I changed back the server template to Not hashed passwords, set a new admin password, did a re-send the signup email - still no password included. No difference to the setup with hashed passwords. What do i wrong?

Also it is not working to recover password with following error:

Password recovery failed : Your virtual servrer password for login cannot be recovered as it has not been stored by Virtualmin. Please contact your system administrator to reset the password.

Thx in advance

I have virtualmin 4.06, and I have similar issue.

When I try to Re-Send Signup Email my ${PASS} variable is empty , but if mail sent when I just created virtual server password is in ${PASS} variable and user get his password via email.

I am having the same issue here.
I am using $[PLAINPASS} in the new mail signup configuration file, but unfortuanately password is blank. If I use $[PASS} instead, i get a bizzare password which is not the correct one.

I am using hashed passwords in virtualmin. Is it possible to send the password if you are using hashed passwords in virtualmin?