Weird Email Delivery Problem

I got Virtualmin GPL installed on a Centos VPS, there are currently five virtual servers (5 domains). For 3 domains I turned email off in
Virtualmin–>Domain–>Edit Virtual Server by deselecting accept mail, virus and spam scanning.

For the default domain (which is also the hostname) I have activated catchall by entering Virtualmin–>Domain–>Edit Users–>default username–>Email Settings: @defaultdomain.tld. I also left the autogenerated user@defaultdomain.tld as primary address.

For domain2.tld I have only user@domain2.tld as primary address actived (which I use). But I would also like to create an additional email user for a separate person in that domain.

Now, if I create an additional user via Virtualmin–>Domain2–>Edit Users–>username–>Email Settings–>Add a user to this server this won’t work. The account for the new user is created as user.domain2.tld, he can log in without problems and also send email, but incoming email still goes to the defaultdomain.tld inbox.

Is there something I am doing wrong?


There can sometimes be problems with having a Virtual Server that’s also the hostname of your server.

Is your server’s hostname in the FQDN format – host.domain.tld?

If not, I would recommend changing your hostname to that (in Webmin -> Networking -> Network Configuration -> Hostname and DNS Client), and then not making a Virtual Server with that name.


what you suggested worked perfectly, thanks.

I had defaultdomain.tld as hostname, changed to subdomain.defaultdomain.tld