Website ftp user doesn't work

When I create an user with edit user -> add website ftp user it create an user but he can’t access the public_html but only his own directory.
If I create a single user using the batch create users and setting the ftp-flag=3 it creates an user that can manage the web site.

Howdy,

Hmm, what you’re describing sounds like the user that’s created is being created using Edit User -> Add a user to this server. That would create a user that doesn’t have permission to write to public_html, or any of the sub-directories.

However, the option you mentioned, “Add a website FTP access user”, that creates a user whose home directory is within the public_html folder, and has permission to write there.

Can you verify that the user being added is created with the “Add a website FTP access user” option?

-Eric

I click the up right link “Add a website FTP access user.” and it opens a page “Create FTP User”. But the user created has “no access” under the “Login access” row. When I edit the account the page show “Edit FTP User” so it was created with the right procedure.

Looking to the user shell I notice that it was assigned “/dev/null” instead of “/bin/false” that the batch procedure assign. If I manually assign the “/bin/false” shell access the user can manage the site.

I don’t know where to cange the default shell for ftp users.

I’m using CentOS Linux 6.3 and 3.94.gpl GPL

Ah, what you’re seeing is a bug in the 3.94 release… a 3.94-1 version will be out shortly to resolve that.

-Eric