webpage is not available after reboot at fresh Virtualmin installation

I just successfully installed and configured Virtualmin on Linode Ubuntu 12.04 LTS. The webpage asked me to reboot. Unfortunately, after I reboot, my https://ipaddress:10000/ shows “webpage is not available”.

I first tried:

/etc/init.d/webmin start

update-rc.d webmin defaults

I got the following message:

update-rc.d: warning: webmin start runlevel arguments (2 3 4 5) do not match LSB Default-Start values (2 3 5)

System start/stop links for /etc/init.d/webmin already exist.

I then tried:

cd /etc/init.d

rm …/rc?.d/???webmin

update-rc.d webmin defaults

I got the following message:

update-rc.d: warning: webmin start runlevel arguments (2 3 4 5) do not match LSB Default-Start values (2 3 5)

Adding system startup for /etc/init.d/webmin …
/etc/rc0.d/K20webmin -> …/init.d/webmin
/etc/rc1.d/K20webmin -> …/init.d/webmin
/etc/rc6.d/K20webmin -> …/init.d/webmin
/etc/rc2.d/S20webmin -> …/init.d/webmin
/etc/rc3.d/S20webmin -> …/init.d/webmin
/etc/rc4.d/S20webmin -> …/init.d/webmin
/etc/rc5.d/S20webmin -> …/init.d/webmin

I am totally newbie, please help! Thanks, Amy.

Howdy,

Well, let’s start here – when you started the Webmin process from the command line, did it work properly at that point?

-Eric

root@alex:~# /etc/init.d/webmin start

root@alex:~#

I modified the “Default-Start from 2 3 5 to 2 3 4 5” in /etc/init.d/webmin file, as attached. Now, I got the following message:

root@alex:~# sudo update-rc.d webmin defaults

Adding system startup for /etc/init.d/webmin …

/etc/rc0.d/K20webmin -> …/init.d/webmin

/etc/rc1.d/K20webmin -> …/init.d/webmin

/etc/rc6.d/K20webmin -> …/init.d/webmin

/etc/rc2.d/S20webmin -> …/init.d/webmin

/etc/rc3.d/S20webmin -> …/init.d/webmin

/etc/rc4.d/S20webmin -> …/init.d/webmin

/etc/rc5.d/S20webmin -> …/init.d/webmin

root@alex:~#

I added the following line to iptables and restarted webmin, problem fixed.

-A INPUT -p tcp -m tcp --dport 10000 -j ACCEPT

http://www.webmin.com/firewall.html